Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162497 - IRQ 177 causes network to stop responding
Summary: IRQ 177 causes network to stop responding
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-05 16:13 UTC by Stuart Bailey
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-16 18:34:32 UTC


Attachments (Terms of Use)
Extract from /var/log/messages (deleted)
2005-07-05 16:14 UTC, Stuart Bailey
no flags Details
exttract from /var/log/messages (deleted)
2005-07-05 16:33 UTC, Stuart Bailey
no flags Details

Description Stuart Bailey 2005-07-05 16:13:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 SUSE/1.0.4-1.1

Description of problem:
An IRQ 177 occurs and shortly afterward, the network interface stops working. All client machines also lockup waiting for the server to respond.

A reboot recovers from the problem.

I will attach an extract from /var/log/messages:


Version-Release number of selected component (if applicable):
2.6.9-1.667smp

How reproducible:
Sometimes

Steps to Reproduce:
1.reboot
2.wait
3....2 weeks later same problem occurs
  

Additional info:

Comment 1 Stuart Bailey 2005-07-05 16:14:26 UTC
Created attachment 116360 [details]
Extract from /var/log/messages

Comment 2 Stuart Bailey 2005-07-05 16:21:02 UTC
A new occurance toady caused the network to again stop working. I will attach an
extract from /var/log/messages again.
This time, acpi and apm have been disabled at the boot prompt.

Also, for info, lspci reports the following hardware:

00:00.0 Host bridge: ALi Corporation: Unknown device 1683
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
00:02.0 PCI bridge: ALi Corporation M5249 HTT to PCI Bridge
00:03.0 ISA bridge: ALi Corporation M1563 HyperTransport South Bridge (rev 20)
00:03.1 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:04.0 Multimedia audio controller: ALi Corporation M5455 PCI AC-Link
Controller Audio Device (rev 10)
00:0e.0 IDE interface: ALi Corporation M5229 IDE (rev c5)
00:0e.1 Ethernet controller: ALi Corporation M5261 Ethernet Controller (rev 30)
00:0f.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0f.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0f.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0f.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200]
(rev a1)
02:07.0 SCSI storage controller: Adaptec AIC-7892A U160/m (rev 02)

The only SCSI device is a HP DAT Tape.

Comment 3 Stuart Bailey 2005-07-05 16:33:31 UTC
Created attachment 116364 [details]
exttract from /var/log/messages

Note: in the log, at 12:00:42 the network was stopped manually by root.

Also, not sure what entry at 12:01:38 - 'switching to MII media' means.

Comment 4 Dave Jones 2005-07-07 22:37:30 UTC
can you try and repeat this on the errata kernel ? 2.6.9 is quite old.


Comment 5 Dave Jones 2005-07-15 19:25:34 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 6 John W. Linville 2005-09-16 18:34:32 UTC
Closed due to lack of response.  Please re-open when the requested test 
results are available...thanks! 


Note You need to log in before you can comment on or make changes to this bug.