Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162493 - Internal compiler error on x86_64 when compiling octave from extras
Summary: Internal compiler error on x86_64 when compiling octave from extras
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL: http://extras64.linux.duke.edu/failed...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-05 16:00 UTC by Quentin Spencer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-18 09:46:57 UTC


Attachments (Terms of Use)

Description Quentin Spencer 2005-07-05 16:00:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When compiling octave from Fedora Extras (the SRPM can be found at http://extras64.linux.duke.edu/failed/development/octave/2.1.71-11.fc5/octave-2.1.71-11.fc5.src.rpm ), the build fails on x86_64 when compiling Array-s.cc due to what g++ calls an internal error.

Version-Release number of selected component (if applicable):
gcc-4.0.0-13

How reproducible:
Didn't try

Steps to Reproduce:
Rebuild the SRPM referenced above on x86_64 (the build appears to complete on i386 and PPC).

Actual Results:  g++ -c  -fPIC -I. -I.. -I../liboctave -I../src -I../libcruft/misc  -DHAVE_CONFIG
_H  -Wall -W -Wshadow -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m64 -mt
une=nocona -D_GNU_SOURCE Array-s.cc -o pic/Array-s.o
g++: Internal error: Killed (program cc1plus)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
make[2]: *** [pic/Array-i.o] Error 1
{standard input}: Assembler messages:
{standard input}:135625: Warning: end of file not at end of a line; newline inse
rtedmake[2]: *** Waiting for unfinished jobs....

{standard input}:136648: Error: suffix or operands invalid for `movq'


Expected Results:  Successful build.

Additional info:

Comment 1 Jakub Jelinek 2005-07-05 21:27:52 UTC
That means either that you or the kernel killed the compiler.
That does not mean there is a compiler bug.
A compiler bug would be if on reasonably large source the compiler ate
excessive amount of memory and OOM killer killed it.
So the question is: 1) how much physical memory and swap do you have
2) run that command again and watch in top how much memory it is using


Comment 2 Jakub Jelinek 2005-08-18 09:46:57 UTC
No feedback provided.


Note You need to log in before you can comment on or make changes to this bug.