Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162481 - adaptx cannot be rebuild on currents -devel system
Summary: adaptx cannot be rebuild on currents -devel system
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: adaptx
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Vadim Nasardinov
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-05 14:12 UTC by Karsten Hopp
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-28 20:44:20 UTC


Attachments (Terms of Use)
log of the unsuccessful build attempt (deleted)
2005-07-05 14:12 UTC, Karsten Hopp
no flags Details

Description Karsten Hopp 2005-07-05 14:12:49 UTC
Description of problem:
adaptx cannot be rebuild on currents -devel system
maybe just a missing build prereq.

Version-Release number of selected component (if applicable):
adaptx-0.9.6-1jpp_1fc

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Karsten Hopp 2005-07-05 14:12:50 UTC
Created attachment 116353 [details]
log of the unsuccessful build attempt

Comment 2 Vadim Nasardinov 2005-11-22 22:18:27 UTC
The log you posted in attachment 116353 [details] suggests that the build failed
due to missing Xerces-J2:

[javac] 46. ERROR in
/builddir/build/BUILD/adaptx/src/main/org/exolab/adaptx/xml/parser/XercesParser.java
[javac]  (at line 42)
[javac]         private org.apache.xerces.parsers.DOMParser parser = null;    
[javac]                 ^^^^^^^^^^^^^^^^^
[javac] org.apache.xerces cannot be resolved to a type

I couldn't reproduce this failure in my environment, but I think I may
have figured this out.

If you run the build manually:

 $ cd adaptx
 $ touch src/main/org/exolab/adaptx/xml/parser/XercesParser.java
 $ ant -verbose -buildfile src/build.xml jar

... you'll notice that Ant puts /usr/share/java/jaxp_parser_impl.jar
on the classpath.  This is because:

| $ cat -n /usr/bin/ant | grep -B1 jaxp
|    151  if $rpm_mode && [ -f /usr/bin/build-classpath ] ; then
|    152    LOCALCLASSPATH="$(/usr/bin/build-classpath ant ant-launcher
jaxp_parser_impl xml-commons-apis)"

jaxp_parser_impl is guaranteed to be present because:

| $ rpm -q --requires ant | grep jaxp
| jaxp_parser_impl  

So, this should always work:

| $ build-classpath jaxp_parser_impl
| /usr/share/java/jaxp_parser_impl.jar

However, there are multiple packages that provide jaxp_parser_impl:

| $ rpm -q --whatprovides jaxp_parser_impl  
| java-1.4.2-gcj-compat-1.4.2.0-40jpp_51rh
| xerces-j2-2.6.2-5jpp_2fc

You probably didn't have xerces-j2 installed, because neither Ant nor
Adaptx requires it.  If Xerces were installed, it would take
precedence over java-1.4.2-gcj-compat-1.4.2.0-40jpp_51rh as a provider
of jaxp_parser_impl:

| $ ls  -l /usr/share/java/jaxp_parser_impl.jar
| lrwxrwxrwx  1 root root 34 Oct  3 16:59 /usr/share/java/jaxp_parser_impl.jar
-> /etc/alternatives/jaxp_parser_impl
| $ readlink -f /usr/share/java/jaxp_parser_impl.jar
| /usr/share/java/xerces-j2-2.6.2.jar

So, that would probably explain why your build failed, but the builds
in beehive always succeeded.  Thanks for catching this.

I went ahead and added xerces-j2 as a requirement for adaptx:

  https://www.redhat.com/archives/fedora-cvs-commits/2005-November/msg01335.html

This is tagged at adaptx-0_9_6-1jpp_2fc, but I can't build it in
beehive at the moment.

Comment 3 Vadim Nasardinov 2005-11-28 20:44:20 UTC
built in rawhide


Note You need to log in before you can comment on or make changes to this bug.