Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162477 - not save new page style when save in Microsoft Win 2000/XP
Summary: not save new page style when save in Microsoft Win 2000/XP
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-05 12:23 UTC by Sergey Bykov
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-22 08:14:50 UTC


Attachments (Terms of Use)

Description Sergey Bykov 2005-07-05 12:23:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I create new page style and add some page with this style and save document in MS 2000/XP format then I lost that page style if close document.
If save in native opendocument format all work fine. :(

This behaviour same for RTF saving format.

Version-Release number of selected component (if applicable):
openoffice.org-writer-1.9.112-1.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1.Choose Format - Styles and Formatting.
2.Click the Page Styles icon.
3.Right-click, and choose New.
4.On the Organizer tab page, type a name for the page style in the Name box.
5.In the Next Style box, select the page style that you want to apply to the next page.
To only apply the new page style to a single page, select "Default".
To apply the new page style to all subsequent pages, select the name of the new page style.
6.Click the Page tab.
7.Under Paper format, select Portrait or Landscape.
8.Click OK.
9. Save documen in MS Win 2000/XP format and close document.
10. Open this document and look at page styles!!!

Actual Results:  Don't save new page styles in documents in format MS Win 2000/XP

Expected Results:  save new page styles in documents in format MS Win 2000/XP

Additional info:

Stable OO 1.1.4 have not this bug.

Comment 1 Caolan McNamara 2005-07-15 14:04:34 UTC
MSWord does not have page styles, so the page styles themselves are not saved in
a .doc document. If they are *used* in a document and saved to .doc format then
as close a match as possible is created and exported as msword sections. On
re-import page styles are re-constructed as best as is possible given the .doc
format.

On exporting: Where pagestyles are used after explicit page breaks which have a
page style applied to them, then they get exported as .doc sections. When a page
style comes into effect because of text flow onto a next page, then the msword
section is placed at the next available explicit page break even if it does not
have a page style explicitly applied to it in writer.

Additionally, word sections can have a different first page to the following
pages. When there is a writer pagestyle pair which can be fit to this model that
conversion is also attempted.

All in all it's really complicated, so I need to see a document attached that
you have that you are not happy with to see if it is being exported correctly
according to the page styles export system.


Note You need to log in before you can comment on or make changes to this bug.