Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162471 - Can't start printconf
Summary: Can't start printconf
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpl
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-05 10:12 UTC by Daniel Malmgren
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-08 13:45:32 UTC


Attachments (Terms of Use)

Description Daniel Malmgren 2005-07-05 10:12:43 UTC
Description of problem:
Printconf refuses to start.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.135-1

How reproducible:
100%

Steps to Reproduce:
1. Try to start system-config-printer or printconf
  
Actual results:
Traceback (most recent call last):
  File "/usr/sbin/printconf", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 32, in ?
    translate.textdomain (domain)
  File "/usr/lib/python2.4/site-packages/rhpl/translate.py", line 213, in textdomain
    cat.setDomain(domain)
  File "/usr/lib/python2.4/site-packages/rhpl/translate.py", line 106, in setDomain
    self.updateCachedCatPaths()
  File "/usr/lib/python2.4/site-packages/rhpl/translate.py", line 133, in
updateCachedCatPaths
    catalog = gettext.GNUTranslations(mofile)
  File "/usr/lib/python2.4/gettext.py", line 177, in __init__
    self._parse(fp)
  File "/usr/lib/python2.4/gettext.py", line 257, in _parse
    buf = fp.read()
  File "/usr/lib/python2.4/gzip.py", line 217, in read
    self._read(readsize)
  File "/usr/lib/python2.4/gzip.py", line 260, in _read
    self._read_gzip_header()
  File "/usr/lib/python2.4/gzip.py", line 161, in _read_gzip_header
    raise IOError, 'Not a gzipped file'
IOError: Not a gzipped file

Comment 1 Tim Waugh 2005-07-05 10:39:44 UTC
What does 'rpm -V system-config-printer' say?

Comment 2 Daniel Malmgren 2005-07-06 05:26:26 UTC
(In reply to comment #1)
> What does 'rpm -V system-config-printer' say?

Nothing at all.

Comment 3 Tim Waugh 2005-07-06 08:14:34 UTC
What does 'locale' say?

Comment 4 Daniel Malmgren 2005-07-06 08:58:10 UTC
Yep. That's it. Locale says:

LANG=sv_SE
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="sv_SE"
LC_PAPER="sv_SE"
LC_NAME="sv_SE"
LC_ADDRESS="sv_SE"
LC_TELEPHONE="sv_SE"
LC_MEASUREMENT="sv_SE"
LC_IDENTIFICATION="sv_SE"
LC_ALL=

...but a simple "export LANG=C" makes printconf work again.

(Hmmm... Suddenly I can't change status to assigned anymore. Guess I'll just
leave it as needinfo.)

Comment 5 Tim Waugh 2005-07-06 09:21:55 UTC
I think that /usr/share/locale/sv/LC_MESSAGES/printconf.mo is unchanged since
FC4, so this seems to be an rhpl bug.

Comment 6 Daniel Malmgren 2005-07-06 09:39:57 UTC
Yep. At a closer examination I get the same error on all the system-config-*
stuff when my locale is set to swedish.

Comment 7 Daniel Malmgren 2005-07-08 13:45:32 UTC
Ok. Fixed in rhpl 0.169. Closing.


Note You need to log in before you can comment on or make changes to this bug.