Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162470 - Can't get hplip to print anything
Summary: Can't get hplip to print anything
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-07-05 10:08 UTC by Daniel Malmgren
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-27 11:52:28 UTC


Attachments (Terms of Use)
Error log (deleted)
2005-07-05 10:08 UTC, Daniel Malmgren
no flags Details

Description Daniel Malmgren 2005-07-05 10:08:35 UTC
Description of problem:
After upgrading from hpoj to hplip I just can't print anything anymore.

Version-Release number of selected component (if applicable):
cups-1.1.23-15
hplip-0.9.3-8
system-config-printer-0.6.135-1

How reproducible:
100%

Steps to Reproduce:
1. Try to print anything using my hp printer
  
Actual results:
Nothing. The document print status claims the printout is finished.

Expected results:
My printer should print!

Additional info:
It's a locally usb connected hp psc1110, which works fine using hpoj. I tried
setting cups to debug mode, attaching log file.

Comment 1 Daniel Malmgren 2005-07-05 10:08:36 UTC
Created attachment 116350 [details]
Error log

Comment 2 Tim Waugh 2005-07-05 10:38:48 UTC
Did you configure the queue using system-config-printer?  If so, please attach
the output of 'printconf-tui --Xexport'.

Comment 3 Daniel Malmgren 2005-07-06 05:28:41 UTC
N(In reply to comment #2)
> Did you configure the queue using system-config-printer?  If so, please attach
> the output of 'printconf-tui --Xexport'.

No. I can't seem to start printconf at all right now (see #162471), so I
configured it using cups web interface. If this is a problem, I guess I'll come
back to this once we've solved the abovementioned bug?

Comment 4 Tim Waugh 2005-07-06 08:15:37 UTC
What does 'getenforce' say?

Comment 5 Daniel Malmgren 2005-07-06 09:04:13 UTC
(In reply to comment #4)
> What does 'getenforce' say?

"Disabled"

I don't use selinux at all.

Comment 6 Tim Waugh 2005-07-06 09:22:33 UTC
Okay, let's see what happens with bug #162471 first.

Comment 7 Daniel Malmgren 2005-07-08 13:54:14 UTC
Ok. Now printconf works again. I can't see the printer at all in printconf
though. In the list of printers I get only one item, "hp:/no_device_found". It
gets stranger though. Here are the results from hp-probe and hp-info:

[~#] hp-probe

 HP Linux Imaging and Printing System (ver. 0.9.3)
 Device Detection (Probe) Utility ver. 1.1

 Copyright (c) 2003-5 Hewlett-Packard Development Company, LP
 This software comes with ABSOLUTELY NO WARRANTY.
 This is free software, and you are welcome to distribute it
 under certain conditions. See COPYING file for more details.

   Device URI                                   Model 
   -------------------------------------------  ------------------ 
   hp:/usb/psc_1100_series?serial=MY378D92CHB0  HP psc_1100_series 
[~#] hp-info

 HP Linux Imaging and Printing System (ver. 0.9.3)
 Device Information Utility ver. 2.8

 Copyright (c) 2003-5 Hewlett-Packard Development Company, LP
 This software comes with ABSOLUTELY NO WARRANTY.
 This is free software, and you are welcome to distribute it
 under certain conditions. See COPYING file for more details.

 [WARNING]: Device not specified.

Choose device from probed devices connected on bus(es) usb,cups:

 Using device: hp:/usb/psc_1100_series?serial=MY378D92CHB0

Info for: hp:/usb/psc_1100_series?serial=MY378D92CHB0

 [ERROR]: Unable to communicate with device:
hp:/usb/psc_1100_series?serial=MY378D92CHB0
 [ERROR]: Error opening device. Exiting.


Comment 8 Daniel Malmgren 2005-07-10 07:19:24 UTC
Just in case it makes any difference, here is the output of hp-info in debug mode:

[~#] hp-info -l debug

 HP Linux Imaging and Printing System (ver. 0.9.3)
 Device Information Utility ver. 2.8

 Copyright (c) 2003-5 Hewlett-Packard Development Company, LP
 This software comes with ABSOLUTELY NO WARRANTY.
 This is free software, and you are welcome to distribute it
 under certain conditions. See COPYING file for more details.

 [WARNING]: Device not specified.

Choose device from probed devices connected on bus(es) usb,cups:

 [DEBUG]: Sending:
'msg=probedevicesfiltered\nfilter=none\nbus=usb,cups\nformat=default\ntimeout=5\nttl=4\n'
 [DEBUG]: Received:
'msg=probedevicesfilteredresult\nresult-code=0\nnum-devices=1\nencoding=none\nlength=60\ndata:\nhp:/usb/psc_1100_series?serial=MY378D92CHB0,psc_1100_seri
es\n' [DEBUG]: ['hp:/usb/psc_1100_series?serial=MY378D92CHB0']
 [DEBUG]: [<cupsext.Printer object at 0xb76ba4e0>]
 Using device: hp:/usb/psc_1100_series?serial=MY378D92CHB0
 [DEBUG]: URI: backend=hp, is_hp=True, bus=usb, model=psc_1100_series,
serial=MY378D92CHB0, dev=, host=, port=1

Info for: hp:/usb/psc_1100_series?serial=MY378D92CHB0

 [DEBUG]: Opening device: hp:/usb/psc_1100_series?serial=MY378D92CHB0
 [DEBUG]: Sending:
'msg=deviceopen\ndevice-uri=hp:/usb/psc_1100_series?serial=MY378D92CHB0\n'
 [DEBUG]: Received: 'msg=MessageError\nresult-code=4\n'
 [DEBUG]: Exception: 4 (Unknown/invalid device-uri field)
 [ERROR]: Unable to communicate with device:
hp:/usb/psc_1100_series?serial=MY378D92CHB0
 [DEBUG]: Exception: 4 (Unknown/invalid device-uri field)
 [ERROR]: Error opening device. Exiting.
 [DEBUG]: Closing services...

Comment 9 Tim Waugh 2005-07-25 09:42:31 UTC
Please upgrade to hplip-0.9.4 (including hpijs).  Does it still happen with 0.9.4-1?

Comment 10 Daniel Malmgren 2005-07-27 11:52:28 UTC
Nope, it seems to be fixed in 0.9.4, so I'll close.

I get this message now, but I'll open another bug for that:

[~#] system-config-printer
No match for USB device:
  mfr "Hewlett-Packard"
  model "psc 1100 series"
  desc ""
  cmdset "LDL,MLC,PML,DYN"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.


Note You need to log in before you can comment on or make changes to this bug.