Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162465 - Menu icon for btdownload-gui package not packaged properly
Summary: Menu icon for btdownload-gui package not packaged properly
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 162765 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-05 08:54 UTC by Axon
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-13 13:42:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 310221 None None None Never

Description Axon 2005-07-05 08:54:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The icon for the extremely useful GUI BitTorrent application does not appear in the menu. This causes minor problems, for example throws an error message when you attempt to add the menu item as a launcher to the desktop panel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A

Additional info:

Comment 1 Paul Howarth 2005-07-05 09:02:09 UTC
Menu item appears OK in gnome here (on the Applications->Internet menu). Which
desktop are you using?


Comment 2 Paul Howarth 2005-07-05 09:19:32 UTC
Also, and this may be obvious but I have to ask: do you have the bittorrent-gui
package installed?

Comment 3 Axon 2005-07-05 10:09:36 UTC
I'm using GNOME desktop with the bittorrent-gui package installed. If it is any
help, I also have the LIVNA and Mono NRPMS YUM repos installed although I'm
fairly sure my packages are getting installed from Fedora extras.

I can provide screenshots if that is helpful.

Comment 4 Paul Howarth 2005-07-05 10:21:14 UTC
If you do a "rpm -qi bittorrent-gui" you can check the source of the package.
The one in extras for FC4 is version "4.0.2", release "1.fc4", and the build
host was "extras64".

There should be a file:
/usr/share/applications/fedora-bittorrent.desktop
the presence of this file should result in there being a menu item available in
all freedesktop.org-aware desktops.

Sometimes (though I haven't been able to reproduce this) the menu item doesn't
appear until you've logged out and back in again after installing
bittorrent-gui. Did you only just install it?


Comment 5 Axon 2005-07-05 19:36:09 UTC
Please ignore: you were correct, restarting Gnome fixes this issue. Apologies
for wasting your time.

Comment 6 Paul Howarth 2005-07-07 08:51:37 UTC
I'll keep my eyes open for ways of getting the icon to appear without restarting
gnome, but in the meantime I'll close the bug.

Comment 7 Mark McLoughlin 2005-07-12 11:26:04 UTC
See:

  https://www.redhat.com/archives/fedora-extras-list/2005-July/msg00610.html

Ricardo: two questions, please:

  1) Did the menu item appear in the panel, but without an icon? Or did the
     menu item not appear in the panel at all?

  2) Does/did /usr/share/pixmaps/icon-theme.cache exist? If so, does removing
     that file fix the problem?

Comment 8 Axon 2005-07-12 11:38:00 UTC
> Did the menu item appear in the panel, but without an icon?

Yes :)

> Does/did /usr/share/pixmaps/icon-theme.cache exist?

Don't know: I'll try and re-install it tonight and check.

Comment 9 Mark McLoughlin 2005-07-13 13:42:01 UTC
So, this turned out to be a genuine bug with GtkIconTheme. See:

  http://bugzilla.gnome.org/show_bug.cgi?id=310221

This should be fixed upstream soon and in rawhide when we get a new release.
Closing UPSTREAM.

Comment 10 Mark McLoughlin 2005-07-13 13:42:40 UTC
*** Bug 162765 has been marked as a duplicate of this bug. ***

Comment 11 Paul Howarth 2005-07-13 14:05:55 UTC
I've moved the icon to /usr/share/icons/hicolor/48x48/apps in cvs anyway. This
will show up in rawhide sometime after the extras build system starts working
again; FC3 and FC4 packages will come along once upstream releases a new
non-beta version, unless someone can persuade me that 4.1.x is stable enough for
the masses :-)


Note You need to log in before you can comment on or make changes to this bug.