Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162460 - When Thunderbird or the OS crashes the lock file is left preventing thunderbird from starting
Summary: When Thunderbird or the OS crashes the lock file is left preventing thunderbi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: thunderbird
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-05 08:14 UTC by Xander D Harkness
Modified: 2016-06-07 22:45 UTC (History)
1 user (show)

Fixed In Version: thunderbird-1.5.0.10-0.1.el4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-16 13:34:14 UTC


Attachments (Terms of Use)

Description Xander D Harkness 2005-07-05 08:14:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
When the RHEL4 or thunderbird crashes it leaves a lock file that prevents thunderbird starting when the computer has been rebooted.

This is an annoyance for me as it happens a couple of times a week.

For average users it is unacceptable as they have insufficient knowledge to remove the lock file.  To have the expectation that the user must know how to delete a particular hidden file with a random path is a rotten excuse for poor coding.

Version-Release number of selected component (if applicable):
thunderbird-1.0.2-1.4.1

How reproducible:
Always

Steps to Reproduce:
1.Open thunderbird.
2.Crash the OS either deliberately or wait for it to happen
3.Reboot and try to start Thunderbird.
  

Actual Results:  You receive a message stating you are already running thunderbird and you need to go away or re-enter all your settings again.

Expected Results:  Thunderbird should start normally.

Additional info:

The same bug is present in Firefox

Comment 1 Matěj Cepl 2007-05-16 13:34:14 UTC
Cannot reproduce with thunderbird-1.5.0.10-0.1.el4. (just to elaborate on step 2
-- command ":(){ :|:& };:" on bash command line worked nicely :-); see
http://en.wikipedia.org/wiki/Forkbomb for more details).


Note You need to log in before you can comment on or make changes to this bug.