Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162446 - Stopping NFS locking: [FAILED]
Summary: Stopping NFS locking: [FAILED]
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-04 21:44 UTC by Andre Robatino
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-06 12:53:16 UTC


Attachments (Terms of Use)
output of "strace -f rpc.lockd" (deleted)
2005-07-04 21:58 UTC, Andre Robatino
no flags Details

Description Andre Robatino 2005-07-04 21:44:55 UTC
Description of problem:
  At shutdown, "Stopping NFS locking:" fails.  If I'm not mistaken, this is
associated with rpc.lockd which belongs to the nfs-utils package.

Version-Release number of selected component (if applicable):
nfs-utils-1.0.7-8

How reproducible:
always

Steps to Reproduce:
1.  Clean workstation install of FC4.
2.  Boot and then shutdown.
  
Actual results:
  "Stopping NFS locking:" returns [FAILED].

Expected results:
  Should return [OK].

Comment 1 Andre Robatino 2005-07-04 21:52:11 UTC
  Forgot to mention that the error persists even with all current updates applied.

Comment 2 Andre Robatino 2005-07-04 21:58:39 UTC
Created attachment 116334 [details]
output of "strace -f rpc.lockd"

Comment 3 Pascal de Bruijn 2005-07-12 16:56:57 UTC
I'm having the same issue. I have all updates applied.

Note, that I'm not using NFS though...

Comment 4 Andre Robatino 2005-07-12 17:03:13 UTC
  Neither am I.  I've done clean FC4 installs on 2 different machines and have
the same problem on both.  My father also has the problem on his machine with a
clean FC4 install.  All of these are workstation installs and none of them use NFS.
  The strace I attached is short and the problem probably very simple.  But
since this service is enabled by default, even if it's not used, the error
should be fixed.

Comment 5 Steve Dickson 2005-07-13 21:19:52 UTC
agreed... its being looked into... 

Comment 6 Phillip Landis 2005-07-14 16:31:19 UTC
I am having the same 'fail' message from nfslock at shutdown. NFS is running
properly.  All updates have been applied.

Please fix!

Comment 7 Jerry 2005-07-17 06:26:52 UTC
I am using NFS and noticed that I have to do a service nfs restart after bootup
to get the nfs export to appear to other machines on my network.  The Stopping
error occurs when I do the restart.  Subsequent restarts show no errors.

Comment 8 Martin 2005-07-21 13:48:27 UTC
I've just compared the script /etc/init.d/nfslock from FC4 with the one from 
FC3:

FC4:
-----------------
<snip>
stop() {
        # Stop daemons.
        echo -n $"Stopping NFS locking: "
        if [ "$USERLAND_LOCKD" ]; then
           killproc lockd
        else
           killproc lockd -KILL
        fi
        echo
        echo -n $"Stopping NFS statd: "
        killproc rpc.statd
        RETVAL=0
        echo
        [ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/nfslock
        return $RETVAL
}
<snip>

FC3:
-----------------
<snip>
stop() {
        # Stop daemons.
        if [ "$USERLAND_LOCKD" ]; then
           echo -n $"Stopping NFS locking: "
           killproc lockd
           echo
        fi
        echo -n $"Stopping NFS statd: "
        killproc rpc.statd
        RETVAL=0
        echo
        [ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/nfslock
        return $RETVAL
}
<snip>

Please note:
The variable $USERLAND_LOCKD is empty on a non-modified FC4 installation.
So why does the lockd process need to be stopped when it isn't started?

if [ "$USERLAND_LOCKD" ]; then
   killproc lockd
else
   killproc lockd -KILL   <- This is the line which causes the failed message.
                             What is this line for? It was missing in FC3.
fi

Maybe this could help...

Comment 9 Steve Dickson 2005-09-06 12:53:16 UTC
Should be fixed in nfs-utils-1.0.7-16

Comment 10 André Fettouhi 2005-11-22 13:07:17 UTC
When will a fix be released for FC4? The problem still exists for
nfs-utils-1.0.7-12.FC4.

Kind Regards

André Fettouhi

Comment 11 Tamas Vincze 2005-12-08 01:11:39 UTC
Stopping the nfs service also stops lockd so I just commented out this section
of /etc/init.d/nfslock to get rid of the annoying [ERROR] message:

# Stop daemons.
#echo -n $"Stopping NFS locking: "
#if [ "$USERLAND_LOCKD" ]; then
#   killproc lockd
#else
#   killproc lockd -KILL
#fi
#echo



Note You need to log in before you can comment on or make changes to this bug.