Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162442 - tetex - texdoctk setup defaults do not fit Fedora
Summary: tetex - texdoctk setup defaults do not fit Fedora
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
: 168625 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-04 19:37 UTC by Michal Jaegermann
Modified: 2013-07-02 23:08 UTC (History)
2 users (show)

Fixed In Version: 3.0-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-11 11:19:53 UTC


Attachments (Terms of Use)
Patch to fix texdoctk bindings (deleted)
2005-07-21 09:07 UTC, Jindrich Novy
no flags Details | Diff

Description Michal Jaegermann 2005-07-04 19:37:34 UTC
Description of problem:

In /usr/share/texmf/texdoctk/texdocrc.defaults one can find programs
like 'ghostview', 'acroread' and 'netscape' - which is not really what
should be expected by default.  Also a default print command should
be rather 'lpr' and not 'lpr -Plp'.

Another problem is that "Settings" dialog in texdoctk is not resizeable,
does not fit on 1024x768 screen and metacity does not allow then reaching
buttons at the bottom and this is the only way to save modified settings
(outside of a possibility of using an editor to edit if you know what).

There is also 'texdoctk' in tetex-2.0.2-21.3 as distrituted with FC3 but
"v.0.5.2 beta 4" seems to have a number of assorted problems on its own.
In particular it does not recognize its own document selections.  Replacing
that file with "v.0.6.0" taken from tetex-3.0 improves the situation
immediately.

Version-Release number of selected component (if applicable):
tetex-3.0-4

Comment 1 Jindrich Novy 2005-07-21 09:05:03 UTC
Attaching patch for the new texdoctk defaults, please let me know if you're
happy with it.

Comment 2 Jindrich Novy 2005-07-21 09:07:16 UTC
Created attachment 117015 [details]
Patch to fix texdoctk bindings

Comment 3 Michal Jaegermann 2005-07-21 14:32:20 UTC
Defaults for texdoctk look now ok with this catch that in FC4, unfortunately,
there is no gv.  A default PS viewer is evince.  I also wonder if htmlview
would not be safer instead of an explicit firefox.

Comment 4 Jindrich Novy 2005-07-21 14:53:59 UTC
Good catch with evince, I'll change the default viewer of PS/PDF to evince then.
The htmlview is planned to be obsoleted soon so the only textual alternative
might be links here or firefox with the GUI.

Comment 5 Michal Jaegermann 2005-07-21 17:37:44 UTC
IIRC htmlview is "obsolete" for the last five years or so. :-)  Something
of that sort is clearly needed anyway.  But if you want to hardwire firefox
then I do not think that this is a big deal.  These are supposed to be
some sane defaults which can be individually adjusted in any case.

Comment 6 Jindrich Novy 2005-09-19 11:37:47 UTC
*** Bug 168625 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2005-09-19 19:43:48 UTC
From User-Agent: XML-RPC

tetex-3.0-6.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.