Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162437 - system-config-nfs always shows Read for share, even if Read/Write
Summary: system-config-nfs always shows Read for share, even if Read/Write
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-nfs
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-04 17:50 UTC by P Jones
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-26 09:46:47 UTC


Attachments (Terms of Use)

Description P Jones 2005-07-04 17:50:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The system-config-nfs gui always shows Read permissions on shares even if Read/Write is selected. /etc/exports shows rw correctly.

Version-Release number of selected component (if applicable):
system-config-nfs 1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1.Create an NFS share using GUI tool.
2.Select Read/Write as permission
3.Close GUI, open again, new share will show as Read only, check /etc/exports, it correctly has rw
  

Additional info:

Comment 1 Nils Philippsen 2005-07-07 14:32:42 UTC
system-config-nfs-1.3.11-0.fc4.1 which has a fix for this should hit the mirrors
shortly.

Comment 2 Jack Malmostoso 2005-07-12 11:21:19 UTC
I am not sure if opening a new bug. Anyway I created an NFS share with system-
config-nfs and I had to add manually to /etc/hosts.allow the hosts allowed to 
use the share.

I think this should be done automagically, right? Thanks for your help.

Comment 3 P Jones 2005-07-19 23:34:25 UTC
Just confirming that the original bug is resolved in the update mentioned above.
I'll leave the bug open for the above poster, although his issue seems to be a
different bug (one that I haven't experienced, btw).

Comment 4 Nils Philippsen 2005-07-26 09:46:47 UTC
Re comment #2: I'm sure that your problems stem from changed /etc/hosts.allow or
/etc/hosts.deny files as I don't have to do this for NFS serving to work. I have
to tweak my firewall settings though, but this isn't something s-c-nfs should be
handling as well.


Note You need to log in before you can comment on or make changes to this bug.