Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162436 - darcs buildrequires latex2html which does not exist on fc3
Summary: darcs buildrequires latex2html which does not exist on fc3
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: darcs
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-04 17:31 UTC by Karanbir Singh
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-28 11:53:16 UTC


Attachments (Terms of Use)

Description Karanbir Singh 2005-07-04 17:31:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050523 CentOS/1.7.8-1.4.1.centos4

Description of problem:
darcs contains BuildRequires:  latex2html
which dosent exist on fc3 / fe3

Version-Release number of selected component (if applicable):
darcs-1.0.3-2.fc3

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild darcs-1.0.3-2.fc3.src.rpm
2.
3.
  

Actual Results:  error: Failed build dependencies:
        latex2html is needed by darcs-1.0.3-2.el4.kb.i386


Additional info:

lates2html seems to be a FC4 package ( its there at : http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/Fedora/RPMS/ ) - but does not exist on FC3 ( http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/os/Fedora/RPMS/ ).

How did it get build for the FC3 Extras ?

Comment 1 Jens Petersen 2005-07-05 03:19:35 UTC
No idea ;-)   but thanks for catching this. :)

Actually it seems the buildrequires for generating docs are not needed
in practice AFAICT since the source tarball comes with 
pre-generated html files anyway.

I removed the unneeded doc buildrequires in cvs now,
so it should get fixed the next time darcs gets built.

Comment 2 Karanbir Singh 2005-07-05 12:27:42 UTC
are there any build /root logs available ? be interesting to see.

I find it surprising that the buildsystem is ignoring a missing BuildRequires
and going ahead with the build anyway.

Comment 3 Michael Schwendt 2005-07-06 08:32:59 UTC
I believe that the yum-modified version of "mach" used in the current build
system ignores "yum install" failures and effectively ignores BuildRequires,
which fail to install [for various reasons].



Note You need to log in before you can comment on or make changes to this bug.