Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162431 - Advansys cards missing from pcitable
Summary: Advansys cards missing from pcitable
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-04 14:40 UTC by Paul Howarth
Modified: 2015-01-04 22:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-08 22:59:31 UTC


Attachments (Terms of Use)

Description Paul Howarth 2005-07-04 14:40:05 UTC
Description of problem:

The Fedora Core 4 installer does not autodetect Advansys SCSI cards in a system,
despite the advansys.ko kernel module being included in the installer initrd. I
believe that this is due to the absence of any data regarding the Advansys
controllers in pcitable. The following entries were present in hwdata on Red Hat
Linux 9, which did not have this problem:

0x10cd  0x1200  "advansys"      "Advanced System Products|ASC1200 [(abp940) Fast
SCSI-II]"
0x10cd  0x1300  "advansys"      "Advanced System Products|ABP940-U / ABP960-U"
0x10cd  0x2300  "advansys"      "Advanced System Products|ABP940-UW"
0x10cd  0x2500  "advansys"      "Advanced System Products|ABP940-U2W"

I don't know if data in the modules.pcimap file is also necessary for
autodetection or not.

I'm working around this by using a driver disk for FC4 but it would be nice if
FC5 "just worked".

Version-Release number of selected component (if applicable):
hwdata-0.158.1-1

How reproducible:
Every time.

Steps to Reproduce:
Try installing FC4 on a system based on an Advansys SCSI card.
  
Actual results:
No SCSI card or attached hard drives detected.

Expected results:
I get to see disk druid.

Additional info:
It's always "fun" installing Fedora on my Advansys-based file/print server. See
http://www.city-fan.org/ftp/contrib/drivers/advansys/ for more references.

Comment 1 Bill Nottingham 2005-07-05 00:50:13 UTC
At this point, PCI ids really should be in the driver itself (and therefore
modules.pcimap.)

Comment 2 Dave Jones 2005-07-08 22:59:31 UTC
Done for FC5. Fix already in rawhide.



Note You need to log in before you can comment on or make changes to this bug.