Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162419 - Python gnome applets cannot request focus
Summary: Python gnome applets cannot request focus
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
: 163351 164149 (view as bug list)
Depends On:
Blocks: EasyFix-Tracker 161299 172615
TreeView+ depends on / blocked
 
Reported: 2005-07-04 12:04 UTC by Luca Bruera
Modified: 2013-03-13 04:48 UTC (History)
2 users (show)

Fixed In Version: 2.10.0-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-08 03:08:34 UTC


Attachments (Terms of Use)
Patch to add Applet.request_focus (deleted)
2005-10-31 22:57 UTC, Ignacio Vazquez-Abrams
no flags Details | Diff

Description Luca Bruera 2005-07-04 12:04:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.4.4

Description of problem:
The version 2.10 of gnome-python-extras does not include a wrapper for the gnome_applet_request_focus method, thus, due to the new focus policies in gnome 2.10, it is not possible to write a python applet including a text entry of a component needing keyboard focus. Old applications need to be ported to this new API, or won't be able to get focus.

Version-Release number of selected component (if applicable):
gnome-python-extras-2.10

How reproducible:
Always

Steps to Reproduce:
1.Run a python applet with a text entry
2.Click on the text entry

  

Actual Results:  No cursor in the text entry, so it is not possible to input text.

Expected Results:  Cursor to appear in the text entry field, and being able to input text.

Additional info:

A wrapper is available in the unstable release (2.11) of this component.

Comment 1 Walter Justen 2005-08-26 10:06:12 UTC
*** Bug 164149 has been marked as a duplicate of this bug. ***

Comment 2 Walter Justen 2005-08-26 10:06:15 UTC
*** Bug 163351 has been marked as a duplicate of this bug. ***

Comment 3 Ignacio Vazquez-Abrams 2005-10-31 22:57:23 UTC
Created attachment 120591 [details]
Patch to add Applet.request_focus

Here's a patch that adds the proper method to 2.10.0.

Comment 4 Ignacio Vazquez-Abrams 2005-11-17 19:59:07 UTC
Is there any possibility of having this patch added? I require it in order for
the new release of deskbar-applet to work properly.

Comment 5 John (J5) Palmieri 2006-02-01 19:33:40 UTC
Should be in next update

Comment 6 Fedora Update System 2006-02-02 16:28:52 UTC
From User-Agent: XML-RPC

gnome-python2-extras-2.10.0-6 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 7 Ignacio Vazquez-Abrams 2006-02-08 03:08:34 UTC
Works here.


Note You need to log in before you can comment on or make changes to this bug.