Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162407 - password protection will not work for SVN
Summary: password protection will not work for SVN
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-04 08:57 UTC by Frank Büttner
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-04 12:31:26 UTC


Attachments (Terms of Use)

Description Frank Büttner 2005-07-04 08:57:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When I access the SVN dir then no dialog for promt for a password is comming.

Version-Release number of selected component (if applicable):
httpd-2.0.52-3.1

How reproducible:
Always

Steps to Reproduce:
1. open a webbrowser
2. open the page https://server/svn/repos

  

Actual Results:  a list of repos is shown

Expected Results:  a password dialog

Additional info:

/etc/httpd/conf.d/subversion.conf:
LoadModule dav_svn_module     modules/mod_dav_svn.so
LoadModule authz_svn_module   modules/mod_authz_svn.so
<Location /svn/repos>
   DAV svn
   SVNPath /home/svnroot
   SSLRequireSSL
   AllowOverride AuthConfig
</Location>

.htaccess file:
AuthType Basic
AuthName "Bitte anmelden"
AuthMySQLUser apache
AuthMySQLPassword PaSsW0Rd
AuthMySQLDB apache
AuthMySQLUserTable benutzer
AuthMySQLNameField benutzer_name
AuthMySQLPasswordField benutzer_passwort
require valid-user

Comment 1 Joe Orton 2005-08-04 12:31:26 UTC
No, putting auth stuff in an .htaccess file won't work, because the location is
being handled directly from the Subversion database.  Put the auth config into
httpd.conf.


Note You need to log in before you can comment on or make changes to this bug.