Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162403 - Python crashes when importing gtksourceview
Summary: Python crashes when importing gtksourceview
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
: 161223 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-04 06:06 UTC by Andi Albrecht
Modified: 2013-04-02 04:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-19 21:14:31 UTC


Attachments (Terms of Use)

Description Andi Albrecht 2005-07-04 06:06:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Python always crashes when importing gtksourceview.

The error message is:
Fatal Python error: can't initialise module gtksourceview

Version-Release number of selected component (if applicable):
gnome-python2-gtksourceview-2.10.0-2.1

How reproducible:
Always

Steps to Reproduce:
1. Start Python
2. "import gtksourceview"
  

Actual Results:  Python crashes with the following error message:
Fatal Python error: can't initialise module gtksourceview

Additional info:

This only happens, with the following gnome-python2 packages installed:

$ rpm -qa |grep gnome-python2

gnome-python2-gnomevfs-2.10.0-1
gnome-python2-extras-2.10.0-2.1
gnome-python2-2.10.0-1
gnome-python2-gtksourceview-2.10.0-2.1
gnome-python2-bonobo-2.10.0-1
gnome-python2-canvas-2.10.0-1
gnome-python2-applet-2.10.0-2.1
gnome-python2-gtkmozembed-2.10.0-2.1
gnome-python2-gtkhtml2-2.10.0-2.1

I manually installed gnome-python2-gnomeprint-2.10.0-2.1 with yum and everything works fine. Looks like a missing dependency.

Comment 1 Michael Schwendt 2005-07-25 21:34:10 UTC
*** Bug 161223 has been marked as a duplicate of this bug. ***

Comment 2 Michael Schwendt 2005-07-25 21:38:37 UTC
I can confirm that installing gnome-python2-gnomeprint manually fixes this:

$ rpm -q gnome-python2-gnomeprint
package gnome-python2-gnomeprint is not installed

$ rpm -q gnome-python2-gtksourceview | grep print
$

$ python
Python 2.4.1 (#1, May 16 2005, 15:19:29) 
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtksourceview
Fatal Python error: can't initialise module gtksourceview
Aborted

$ sudo yum -y install gnome-python2-gnomeprint
[...]
$ rpm -q gnome-python2-gnomeprint
gnome-python2-gnomeprint-2.10.0-2.1

$ python
Python 2.4.1 (#1, May 16 2005, 15:19:29) 
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtksourceview
>>>


Comment 3 Jonathan Blandford 2005-08-19 21:14:31 UTC
Fixed.

Comment 4 Gilboa Davara 2005-08-20 08:39:17 UTC
Any chance of the fix going down from -rawhide to -updates?


Note You need to log in before you can comment on or make changes to this bug.