Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162400 - Yum segfaults after FC4 upgrade from FC3
Summary: Yum segfaults after FC4 upgrade from FC3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-04 05:12 UTC by Kristian McColm
Modified: 2014-01-21 22:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-27 19:47:10 UTC


Attachments (Terms of Use)

Description Kristian McColm 2005-07-04 05:12:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
# yum update
Segmentation fault

This has only occurred since upgrade to FC4 from FC3, have not changed any hardware.

Nothin reported in syslog, not sure how to provide any other information. Have googled around looking for someone with a similar problem but can't find anything.

Suggestions welcome as to how to find the cause of the segfault.

Version-Release number of selected component (if applicable):
yum-2.3.2-7

How reproducible:
Always

Steps to Reproduce:
1.# yum update
2.
3.
  

Actual Results:  # yum update
Segmentation fault


Expected Results:  Yum should run the update process

Additional info:

Comment 1 Rahul Sundaram 2005-07-06 11:03:06 UTC
How did you perform the upgrade? CD/DVD or through yum?

does up2date work?

whats the output of rpm -q yum libxml2-python rpm-python python python-sqlite
python-elementtree

Comment 2 Kristian McColm 2005-07-06 12:36:28 UTC
Upgrade was via DVD

up2date segfaults also:

# up2date
Segmentation fault

output as requested:

# rpm -q yum libxml2-python rpm-python python python-sqlite python-elementtree
yum-2.3.2-7
libxml2-python-2.6.19-1
rpm-python-4.4.1-21
python-2.4.1-2
python-sqlite-1.1.6-1
python-elementtree-1.2.6-4

(In reply to comment #1)
> How did you perform the upgrade? CD/DVD or through yum?
> does up2date work?
> whats the output of rpm -q yum libxml2-python rpm-python python python-sqlite
> python-elementtree

(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
> Description of problem:
> # yum update
> Segmentation fault
> This has only occurred since upgrade to FC4 from FC3, have not changed any 
hardware.
> Nothin reported in syslog, not sure how to provide any other information. 
Have googled around looking for someone with a similar problem but can't find 
anything.
> Suggestions welcome as to how to find the cause of the segfault.
> Version-Release number of selected component (if applicable):
> yum-2.3.2-7
> How reproducible:
> Always
> Steps to Reproduce:
> 1.# yum update
> 2.
> 3.
>   
> Actual Results:  # yum update
> Segmentation fault
> Expected Results:  Yum should run the update process
> Additional info:

(In reply to comment #1)
> How did you perform the upgrade? CD/DVD or through yum?
> does up2date work?
> whats the output of rpm -q yum libxml2-python rpm-python python python-sqlite
> python-elementtree

(In reply to comment #1)
> How did you perform the upgrade? CD/DVD or through yum?
> does up2date work?
> whats the output of rpm -q yum libxml2-python rpm-python python python-sqlite
> python-elementtree



Comment 3 Seth Vidal 2005-07-29 19:09:10 UTC
if up2date is failing to then it is something above either of them.



Note You need to log in before you can comment on or make changes to this bug.