Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162397 - gpg program fails with error loading shared libraries
Summary: gpg program fails with error loading shared libraries
Keywords:
Status: CLOSED DUPLICATE of bug 161859
Alias: None
Product: Fedora
Classification: Fedora
Component: gnupg
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-04 03:56 UTC by Kevin Hart
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 17:53:17 UTC


Attachments (Terms of Use)

Description Kevin Hart 2005-07-04 03:56:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
While trying to run the gpg program (even without any flags) from the gnupg package, the program fails, giving an error message: "gpg: error while loading shared libraries: cannot restore segment prot after reloc: permission denied".

Version-Release number of selected component (if applicable):
gnupg-1.2.6-1

How reproducible:
Always

Steps to Reproduce:
1. Install package gnupg-1.2.6-1.
2. Run "gpg".
  

Actual Results:  Received the aforementioned error: "gpg: error while loading shared libraries: cannot restore segment prot after reloc: permission denied".

Expected Results:  The program "gpg" should have run without error.

Additional info:

I tried re-installing the package with no luck. I googled for the exact error message and found sone things, but nothing matching my problem.

Comment 1 Nalin Dahyabhai 2005-07-05 14:39:32 UTC
Are you using SELinux?  If so, which version of selinux-policy-targeted is
installed?  I ask because this may be a duplicate of bug #161859.

Comment 2 Kevin Hart 2005-07-06 17:48:11 UTC
I'm using selinux-policy-targeted-1.17.30-3.15 ... so it may be a duplicate of
the bug. I'm sorry, but when I searched for my problem I found no fixes. I'll
try the solutions there and post back soon.

Comment 3 Kevin Hart 2005-07-06 17:51:07 UTC
Yes, 16 worked for me. I'm sorry I didn't see this before, but I do believe it's
a duplicate. Again, I'm sorry, but thank you for pointing that bug out to me, Nalin.

Comment 4 Kevin Hart 2005-07-06 17:53:17 UTC

*** This bug has been marked as a duplicate of 161859 ***


Note You need to log in before you can comment on or make changes to this bug.