Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162393 - move gnutls-cli to different subpackage than -devel
Summary: move gnutls-cli to different subpackage than -devel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnutls
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Depends On: 162480
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-03 23:43 UTC by Ben
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-13 19:26:30 UTC


Attachments (Terms of Use)

Description Ben 2005-07-03 23:43:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050602 Galeon/1.3.21

Description of problem:
The gnutls-cli client program is not installed by default. However, future versions of Emacs (and possibly other scripts?) use and require it. This program would be very useful to add to the RPM!

(I am using the CVS Emacs from Jens Petersen's repository, which now requires it to do STARTTLS authentication.)

Thanks.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

  

Additional info:

Comment 1 Tomas Mraz 2005-07-04 20:37:57 UTC
This binary cannot be part of the library package because it would make multilib
installs on 64bit systems conflict. It is part of the gnutls-devel RPM. Of
course it is questionable if another subpackage (gnutls-utils) shouldn't be
created for this and other binaries from gnutls.


Comment 2 Tomas Mraz 2005-07-05 14:10:58 UTC
gnutls-utils subpackage created. I've filled a bug to add it to the install as
optional package.


Comment 3 Tomas Mraz 2005-07-13 19:26:30 UTC
OK, as the gnutls-utils has been added to comps as optional package to install
this should be fairly enough to close this bug as fixed.



Note You need to log in before you can comment on or make changes to this bug.