Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162389 - Oops when accessing CD drive
Summary: Oops when accessing CD drive
Keywords:
Status: CLOSED DUPLICATE of bug 162347
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-03 22:36 UTC by Per Nystrom
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 15:25:59 UTC


Attachments (Terms of Use)
outptu of lshal (deleted)
2005-07-06 08:36 UTC, Dimitri Papadopoulos
no flags Details

Description Per Nystrom 2005-07-03 22:36:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
After updating to kernel-2.6.12-1.1387_FC4, I get an Oops when the CD drive is accessed.  Sorry, I have not transcribed the Oops output and I'm not set up to do a serial console or net dump.

This happens any time the CD drive is accessed, even at boot time if there's media in the drive.

I'm on a P4 system with just the FC4 installation and updates.  Reverting to kernel 2.6.11-1.1369_FC4 solves the problem.  This is the CD drive, as reported by cdrecord --scanbus:

scsibus1:
        1,0,0   100) 'SONY    ' 'CD-RW  CRX160E  ' '1.0e' Removable CD-ROM


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1387_FC4

How reproducible:
Always

Steps to Reproduce:
1. Install FC4
2. Use yum or similar to get latest updates
3. Oops when CD is accessed
  

Actual Results:  OOPS

Expected Results:  no OOPS

Additional info:

Comment 1 Dimitri Papadopoulos 2005-07-06 08:36:23 UTC
Created attachment 116400 [details]
outptu of lshal

Similar problem here.

I get a kernel error when booting is a DVD is present in my DVD-drive when
booting. In my case removing the DVD fixes the problem. After boot-time, I can
use the DVD drive without problem.

This happens since upgrading to 2.6.12-1.1387_FC4. It didn't happen with
2.6.11-1.1369_FC4.

Since this happens at home I don't have another PC to log kernel messages to,
sorry.

Comment 2 Per Steinar Iversen 2005-07-06 09:01:39 UTC
I see this kind of oops too, but on x86_64 - when using dd to make an ISO image
of a cd.
My drive is "_NEC DVD_RW ND-3520A, ATAPI CD/DVD-ROM drive" according to dmesg.

The previous kernel does not have this problem, though it complains a bit about
the cd during copying, there is possibly a scratch on it.


Comment 3 Alexandre Oliva 2005-07-06 15:25:59 UTC

*** This bug has been marked as a duplicate of 162347 ***


Note You need to log in before you can comment on or make changes to this bug.