Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162387 (Vanishing_Icons_Case) - [kde] Menu Icons on Open Office/Firefox vanish when mouse hovers over them
Summary: [kde] Menu Icons on Open Office/Firefox vanish when mouse hovers over them
Keywords:
Status: CLOSED NOTABUG
Alias: Vanishing_Icons_Case
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-03 22:03 UTC by kuiskers
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-12 08:43:14 UTC


Attachments (Terms of Use)

Description kuiskers 2005-07-03 22:03:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The icons in the menu bar and the drop-down menus of Open Office disappear when the mouse hovers over them. Then the entire menu bar icons disapear, and occasionally one icon will reappear, willy-nilly. The program works, however, but making menu choices is possible only with the utmost caution.

This happens when the KDE Control Centre module, GTK Styles & Fonts, is set to "use my KDE styles in GTK applications". The problem disappears when "use another style" is set to 'Clearlooks'.

Version-Release number of selected component (if applicable):
open office suite 1.9.112-1.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1. Start Open Office and hover the mouse over any icon. Entire menu iconset disappears.
2. Repeat, ad infinitum.
3.
  

Actual Results:  The problem reappeared, ad infinitum.

Expected Results:  1. The menu icons whould remain visible so that a user can see what is being selected. They should not disappear and jump around, reappearing here and there, only to disappear again.

2. All programs should have the same style and window decorations as selected in the Control Centre.

Additional info:

It should be noted that I have a clean install of FC4, not an upgrade, with all the released updates installed, with a preference for official updates, then extras, and finally kde-redhat. My KDE system is KDE-redhat for FC4, again, with all the released updates installed.

It should be noted that a similar problem exists with Firefox, using the KDE styles. The icons in the menu bar are simply not there, although they are replaced by static 'no picture available' icons. By customizing the toolbar to use only small icons, the problem disappears and small versions of the correct menu bar cons appear. Again, by selecting 'Clearlooks' instead of the KDE style, the problem disappears.

Comment 1 Christian Nolte 2005-07-04 20:26:23 UTC
I can verify this. 

gtk-qt version 0.6
kde version 3.4.1
openoffice version 1.9.112-1.1.0.fc4

Comment 2 Caolan McNamara 2005-07-05 07:37:34 UTC
Recently at http://www.openoffice.org/issues/show_bug.cgi?id=50857 there was
some discussion about some similiar sounding problems...

e.g.

// KDE 3.3 invented a bug in the qt<->gtk theme engine
// that makes direct rendering impossible: they totally
// ignore the clip rectangle passed to the paint methods

caolanm->than: if it affects OOo and mozilla, any insights ?

Comment 3 Ngo Than 2005-07-05 09:04:37 UTC
i'm not able to reproduce this problem in FC4 with qt-3.3.4-15.1, and
kde-3.4.1-0.fc4, gtk-qt-engine-0.60-1.

Which KDE theme are you using? and have you installed the KDE-3.4.1 from Fedora4?
Could you please attach the output of "rpm -qa | grep kde". Thanks

Comment 4 kuiskers 2005-07-06 06:33:45 UTC
$ rpm -qa | grep kde
lockdev-1.0.1-7
digikamimageplugins-0.7.2-1.0.3.kde
kdebindings-3.4.1-1.2.fc4.kde
kdeedu-3.4.1-1.2.fc4.kde
amarok-1.2.4-6.1.fc4.kde
kdetoys-3.4.1-1.2.fc4.kde
kdenetwork-devel-3.4.1-1.2.fc4.kde
kdegraphics-devel-3.4.1-1.3.fc4.kde
ImageMagick-perl-6.2.3.0-0.1.fc4.kde
digikam-0.7.2-1.0.fc4.kde
arts-devel-1.4.1-1.2.fc4.kde
kde-i18n-German-3.4.1-1.0.kde
ImageMagick-c++-6.2.3.0-0.1.fc4.kde
knemo-0.3.1-0.1.fc4.kde
kdegraphics-3.4.1-1.3.fc4.kde
kdepim-3.4.1-1.3.fc4.kde
kdepim-devel-3.4.1-1.3.fc4.kde
arts-1.4.1-1.2.fc4.kde
kdelibs-3.4.1-1.2.fc4.kde
kdemultimedia-3.4.1-1.2.fc4.kde
kdeutils-3.4.1-1.2.fc4.kde
kdewebdev-3.4.1-1.2.fc4.kde
dbus-devel-0.33-3.0.fc4.kde
kdeutils-devel-3.4.1-1.2.fc4.kde
kdebase-devel-3.4.1-1.2.fc4.kde
lockdev-devel-1.0.1-7
wv2-0.2.2-4.0.fc4.kde
kdelibs-devel-3.4.1-1.2.fc4.kde
kdeaccessibility-3.4.1-1.2.fc4.kde
dbus-qt-0.33-3.0.fc4.kde
kdebindings-devel-3.4.1-1.2.fc4.kde
kdeaccessibility-kttsd-gstreamer-3.4.1-1.2.fc4.kde
ImageMagick-6.2.3.0-0.1.fc4.kde
kmplayer-0.8.4-0.2.a.3.kde
kdebase-3.4.1-1.2.fc4.kde
kdeaddons-3.4.1-1.2.fc4.kde
k3b-0.12.1-1.1.fc4.kde
kdeartwork-3.4.1-1.2.fc4.kde
kdeadmin-3.4.1-1.2.fc4.kde
koffice-1.4.0a-0.1.fc4.kde
kde-i18n-British-3.4.1-0.fc4.1
kde-i18n-French-3.4.1-1.0.kde
wordtrans-kde-1.1pre13-10
qscintilla-1.5.1-0.0.fc4.kde
kdenetwork-3.4.1-1.2.fc4.kde
kdegames-3.4.1-1.2.fc4.kde
k3b-mp3-0.12.1-1.1.fc4.kde
kdesdk-3.4.1-1.2.fc4.kde

As well, I have qt 3.3.4-15.1 and gtk-qt-engine 0.60-1

Comment 5 Caolan McNamara 2005-07-10 15:17:15 UTC
Might as well reassign to kde as it reportedly affects not just OOo

Comment 6 Ngo Than 2005-07-12 08:43:14 UTC
You are using the KDE packages, which are not from Fedora!
I cannot reproduce this bug with KDE-3.4.1 from FC4 updates. Please install
KDE-3.4.1 packages from FC4 updates.


Note You need to log in before you can comment on or make changes to this bug.