Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162386 - vt's blank after x11 starts
Summary: vt's blank after x11 starts
Keywords:
Status: CLOSED DUPLICATE of bug 162385
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-03 20:53 UTC by Paul Dickson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-03 21:10:08 UTC


Attachments (Terms of Use)

Description Paul Dickson 2005-07-03 20:53:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050620 Firefox/1.0+

Description of problem:
Some change between xorg-x11-6.8.2-31 and xorg-x11-6.8.2-37 causes the vt's (1 through 6) to be displayed as blank screens (only the backlight is on).  The contents of the vt is there (I can login and ps from gnome-terminal shows the login), but nothing is displayed on the vt screen.

This is on my Dell Inspiron 6000, which needs updated drivers to use the i915 video.  I replace three X11 file with version from http://dri.freedesktop.org/snapshots.  Attached is the shell script I use to download these files.

    Files being replaced:
      /usr/X11R6/lib/libGL.so.1.2
      /usr/X11R6/lib/modules/dri/i915_dri.so
      /usr/X11R6/lib/modules/drivers/i810_drv.o

If I don't download the above files, then x11 won't start and I don't have the vt to fall back to.  I can only do a Ctl-Alt-Del so the system will shutdown and reboot.

00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

For other reasons, I run rhgb using the VESA driver.  But during that period I can switch to vt1 and see the output.

This problem exists in 6.8.2-38 and 6.8.2-40.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37

How reproducible:
Always

Steps to Reproduce:
1. From 6.8.2-31 and the 915 chip set, install 6.8.2-37 
2. reboot
3. Replace the three files if you wish to get the system working under the chipset rather than the slow VESA driver.
4. Ctl-Alt-Fn (where n=any of 1-6)

Actual Results:  I get a blank screen (dark) with only the back light on.

I can login blindly, but I can't see what's supposed to be on the screen.

Expected Results:  I should be given a login display.

Additional info:

Comment 1 Paul Dickson 2005-07-03 21:10:08 UTC

*** This bug has been marked as a duplicate of 162385 ***


Note You need to log in before you can comment on or make changes to this bug.