Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162378 - file won't recognize Reiserfs due to 64 kbyte check limit
Summary: file won't recognize Reiserfs due to 64 kbyte check limit
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: file
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-03 13:11 UTC by István Tóth
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.13-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-04 05:40:36 UTC


Attachments (Terms of Use)
This patch makes file chek the first 128kbytes of the file (deleted)
2005-07-03 13:14 UTC, István Tóth
no flags Details | Diff

Description István Tóth 2005-07-03 13:11:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The file command does not recognize ReiserFS filesystems.

Version-Release number of selected component (if applicable):
file-4.13-4

How reproducible:
Always

Steps to Reproduce:
1.mkfs.reiser /dev/VG1/lvol3
2.issue file -Ls /dev/VG1/lvol3
3.
  

Actual Results:  file identifies the volume as "Data"

Expected Results:  File should have been identified as "Filesystem ReiserFS"

Additional info:

It's caused by the fact that the ReiserFS magic string is not in the first 64kbyte of the volume, and file only reads the first 64k of the volume.

Comment 1 István Tóth 2005-07-03 13:14:18 UTC
Created attachment 116309 [details]
This patch makes file chek the first 128kbytes of the file

The attached patch fixes the problem.

Comment 2 Radek Vokal 2005-07-04 05:40:36 UTC
Thanks, patch applied on rawhide. 


Note You need to log in before you can comment on or make changes to this bug.