Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162373 - comparisons like X<=Y<=Z do not have their mathematical meaning
Summary: comparisons like X<=Y<=Z do not have their mathematical meaning
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: memtest86+
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-03 12:08 UTC by David Binderman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-11 10:56:01 UTC


Attachments (Terms of Use)

Description David Binderman 2005-07-03 12:08:54 UTC
Description of problem:

I just tried to compile package memtest86+-1.55.1-1 from Redhat
Fedora Core development tree with the gcc 4.0.0 compiler and
the compiler flag -Wall.

The compiler said

main.c:424: warning: comparisons like X<=Y<=Z do not have their mathematical meaning

The source code is

	for (v->pass_ticks=0, i=0; i<DEFTESTS != NULL; i++) {

I agree with the compiler. Suggest rework code for maintainability.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Warren Togami 2005-09-04 10:07:45 UTC
Upstream, is this fixed in the latest release?


Comment 2 Samuel D. 2005-09-04 14:13:55 UTC
This bug is planned for fix in the upcoming release.

Comment 3 Warren Togami 2005-09-11 10:56:01 UTC
Closing because it is assured to be in the next release which we will pull into
rawhide.


Note You need to log in before you can comment on or make changes to this bug.