Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162359 - Kernel panics when mounting dvd media
Summary: Kernel panics when mounting dvd media
Keywords:
Status: CLOSED DUPLICATE of bug 162347
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL: http://fredrik.nocrew.org/fc4-mount-p...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-03 09:31 UTC by Fredrik Noring
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 15:25:58 UTC


Attachments (Terms of Use)
Kernel call trace on console when panicking (deleted)
2005-07-03 09:33 UTC, Fredrik Noring
no flags Details

Description Fredrik Noring 2005-07-03 09:31:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; sv-SE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Inserting a dvd media in the dvd device and then mounting /media/cdrecorder produces a kernel panic.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1387_FC4

How reproducible:
Always

Steps to Reproduce:
1. Insert a dvd media in the dvd device
2. mount /media/cdrecorder


Actual Results:  The system froze completely and the kernel printed an error message on the console.

Expected Results:  The media should have been mounted.

Additional info:

Comment 1 Fredrik Noring 2005-07-03 09:33:23 UTC
Created attachment 116308 [details]
Kernel call trace on console when panicking

Comment 2 Fredrik Noring 2005-07-03 14:12:15 UTC
Previous kernel 2.6.11-1.1369_FC4 works without crashing. It does however print
the following messages when mounting:

hdb: command error: status=0x51 { DriveReady SeekComplete Error }
hdb: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
ide: failed opcode was: unknown
ATAPI device hdb:
  Error: Illegal request -- (Sense key=0x05)
  Read of scrambled sector without authentication -- (asc=0x6f, ascq=0x03)
  The failed "Read 10" packet command was:
  "28 00 00 3b 3b a0 00 00 02 00 00 00 00 00 00 00 "
end_request: I/O error, dev hdb, sector 15527552
Buffer I/O error on device hdb, logical block 3881888
Buffer I/O error on device hdb, logical block 3881889
hdb: command error: status=0x51 { DriveReady SeekComplete Error }
hdb: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
ide: failed opcode was: unknown
ATAPI device hdb:
  Error: Illegal request -- (Sense key=0x05)
  Read of scrambled sector without authentication -- (asc=0x6f, ascq=0x03)
  The failed "Read 10" packet command was:
  "28 00 00 3b 3b a0 00 00 02 00 00 00 00 00 00 00 "
end_request: I/O error, dev hdb, sector 15527552
Buffer I/O error on device hdb, logical block 3881888
Buffer I/O error on device hdb, logical block 3881889


Comment 3 Andre Robatino 2005-07-03 17:12:48 UTC
  I verified that this happens when attempting to mount a blank DVD, but not
when mounting an already written data DVD.  It also happens for me when trying
to mount a video DVD.  I reported this in bug #162295.

Comment 4 Alexandre Oliva 2005-07-06 15:25:58 UTC

*** This bug has been marked as a duplicate of 162347 ***


Note You need to log in before you can comment on or make changes to this bug.