Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162353 - kernel panic
Summary: kernel panic
Keywords:
Status: CLOSED DUPLICATE of bug 162347
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-03 00:31 UTC by acount closed by user
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 15:25:24 UTC


Attachments (Terms of Use)
crash (deleted)
2005-07-03 00:31 UTC, acount closed by user
no flags Details

Description acount closed by user 2005-07-03 00:31:24 UTC
I just updated to kernel-2.6.12-1.1387_FC4 but it does not boot.

It crashed in rc.sysinit after "Setting hostname..........", maybe it's an ACPI bug.


kernel-2.6.11-1.1369_FC4 works OK.


-thanks-

Comment 1 acount closed by user 2005-07-03 00:31:26 UTC
Created attachment 116302 [details]
crash

Comment 2 acount closed by user 2005-07-03 00:51:49 UTC
It was not APCI. The bug happened with LVM, here in rc.sysinit:

# LVM2 initialization
if [ -x /sbin/lvm.static ]; then
    if ! LC_ALL=C fgrep -q "device-mapper" /proc/devices 2>/dev/null ; then
        modprobe dm-mod >/dev/null 2>&1
    fi
    echo "mkdmnod" | /sbin/nash --quiet >/dev/null 2>&1
    [ -n "$SELINUX" ] && restorecon /dev/mapper/control >/dev/null 2>&1
    if [ -c /dev/mapper/control -a -x /sbin/lvm.static ]; then
        if /sbin/lvm.static vgscan --mknodes --ignorelockingfailure > /dev/null
2>&1 ; then
            action $"Setting up Logical Volume Management:" /sbin/lvm.static
vgchange -a y --ignorelockingfailure
        fi
    fi
fi

and no LVM was setup here.


Comment 3 Alexandre Oliva 2005-07-06 15:25:24 UTC

*** This bug has been marked as a duplicate of 162347 ***


Note You need to log in before you can comment on or make changes to this bug.