Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162329 - exec-shield in 2.6.11-1.35_FC3 blocks some OpenGL apps
Summary: exec-shield in 2.6.11-1.35_FC3 blocks some OpenGL apps
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-02 19:22 UTC by Radek Liboska
Modified: 2015-01-04 22:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 08:15:41 UTC


Attachments (Terms of Use)

Description Radek Liboska 2005-07-02 19:22:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-1.3.1

Description of problem:
Some OpenGL 3D games like lsdldoom or q3demo crash upon starting with "Segmentation Fault" when the  kernel-2.6.11-1.35_FC3 default value (2) of /proc/sys/kernel/exec-shield is set.
$ echo 1 > /proc/sys/kernel/exec-shield
solves the problem.
(Graphic driver:
kernel-module-nvidia-2.6.11-1.35_FC3-1.0.7664-0.lvn.1.3
CPU: AMD Athlon)



Version-Release number of selected component (if applicable):
kernel-2.6.11-1.35_FC3

How reproducible:
Always

Steps to Reproduce:
1.cd /usr/local/games/doom
2../lsdldoom
3.
  

Actual Results:  ...
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

Expected Results:  start the application

Additional info:

The information of the exec-shield should be emphasized. It is extremely tough task find the reason why many applications are dead after upgrade of the kernel.

Comment 1 Dave Jones 2005-07-15 18:27:47 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.