Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162322 - fc4 anaconda install fails to grow lvm if insufficient space
Summary: fc4 anaconda install fails to grow lvm if insufficient space
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-02 15:45 UTC by James Hunt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-08 18:37:13 UTC


Attachments (Terms of Use)

Description James Hunt 2005-07-02 15:45:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I attempted to upgrade an FC3 box to FC4 today, but the install failed since it (correctly) detected that /usr was 65Mb too small for the install to suceed. However, having booted back into FC3, "vgdisplay|grep Free" showed oodles of space left in the Volume Group.

Please could the installer be upgraded to run, "vgdisplay|grep Free", and if space could be made available, offer the user the option of resizing the LV automatically (ie "umount /usr && lvextend -L<some_value> <lv> && e2fsck -f <lv> && resize2fs <lv> && e2fsck -f <lv> && mount /usr")

Of course there is a work around (if you know what you're doing! ;-): boot from the Recovery CD, and use the "lvm" command to do an "lvextend" on /usr. Having done this, the 2nd attempt at the FC4 upgrade worked fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Ensure /usr is almost full on your FC3 box.
2. Ensure that you have lots of spare space in the Volume Group that /usr 
   belongs to.
3. Attempt to upgrade to FC4.


Actual Results:  upgrade popped up a box saying upgrade would not continue (or summut) due to insuffient space.


Expected Results:  The box that pops up stating that 'x' Mb / Gb / etc are required for the install to succeed should provide the option of grabbing the required space from the free pool in the Volume Group (if user is using LVM/LVM2) and if of course there actually *is* sufficient free space in the VG ;-)


Additional info:

I think this change is required since newbies who already have an FC3 system may not relish the idea of hacking around with lvm commands, and could get frustrated. I realize that FC4 comes with system-config-lvm, but of course FC3 doesn't... ;-)

Weirdly, seems that a fresh FC4 system installs system-config-lvm, but an upgrade doesn't....?

If the installer is changed, maybe it would also be wise to explain to the user that this could take a few minutes to complete (if we do the paranoid double e2fsck ;-)

Comment 1 Jeremy Katz 2005-07-08 18:37:13 UTC
Doing this is a part of a bigger effort which would be to add generic partition
resizing.


Note You need to log in before you can comment on or make changes to this bug.