Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162308 - dkms should Require: kernel-devel package
Summary: dkms should Require: kernel-devel package
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dkms
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-02 09:27 UTC by Alex Lancaster
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-12 18:20:35 UTC


Attachments (Terms of Use)

Description Alex Lancaster 2005-07-02 09:27:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
In Fedora Core 4 the headers and Makefiles have been split out of the main "kernel "package into a separate "kernel-devel" package, which may not necessarily be installed.  dkms cannot rebuild modules upon reboot into a new kernel without those headers, so dkms should have "Require: kernel-devel" in it's spec file to enable correct functioning.

Version-Release number of selected component (if applicable):
dkms-2.0.5.2-4.fc4

How reproducible:
Always

Steps to Reproduce:
1. Remove kernel-devel package if installed on FC4 system (yum remove kernel-devel).
2. Install dkms.
3. Add a new package which uses dkms such as kernel_ppp_mppe.
4. Reboot.
  

Actual Results:  dkms cannot build the kernel module on the fly at reboot because it can't find /lib/modules/2.6.11-1.1369_FC4/build directory

Expected Results:  When dkms was yum installed it should have also installed kernel-devel.

Additional info:

Comment 1 Alex Lancaster 2005-07-02 09:30:15 UTC
The kernel_ppp_mppe package comes from:

http://pptpclient.sourceforge.net/howto-fedora-core-4.phtml

Comment 2 Alex Lancaster 2005-07-02 09:35:07 UTC
In fact the page mentioned above, had to add a note to explicitly install
kernel-devel when it really should have been installed automatically upon dkms
install:

"2005-07-02 Added requirement for kernel-devel package, thanks to Ted Rule, Paul
Howarth, and epsilon."

If kernel-smp is also installed then kernel-devel-smp should also be installed,
but I don't know how you would clue the spec file into that.

Comment 3 Alex Lancaster 2005-09-12 18:07:22 UTC
Just pinging to see whether this bug has been seen at all.  The latest dkms
(built Sep 05, 2005) has not addressed this issue.

Comment 4 Tom "spot" Callaway 2005-09-12 18:20:35 UTC
kernel-smp-devel actually provides:
kernel-devel = 2.6.13-1.1549_FC5smp

So, I think kernel-devel is enough of a Requires.

Fixed in 2.0.6-2


Note You need to log in before you can comment on or make changes to this bug.