Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162304 - VNC module on FC4 / gnome corrupts display
Summary: VNC module on FC4 / gnome corrupts display
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2005-07-02 06:10 UTC by Srini
Modified: 2013-04-30 23:33 UTC (History)
3 users (show)

Fixed In Version: 4.1.2-6.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-18 17:15:40 UTC


Attachments (Terms of Use)
Screenshots of the corrupted screen as requested (deleted)
2005-07-08 14:56 UTC, Srini
no flags Details
Improved vncHooks.cc:vncHooksComposite that might solve this problem (deleted)
2005-08-17 08:37 UTC, Peter Åstrand
no flags Details

Description Srini 2005-07-02 06:10:57 UTC
Description of problem:
I load vnc as a module via xorg.conf .. When I login remote now, the display
gets corrupted with each application screen message or movement of cursor etc. 
For eg, if on scrolling a list box, messages are displayed within the dialog,
these messages are displayed on the screen now (one on top of the other) and the
display gets corrupted.


Version-Release number of selected component (if applicable):
FC4

How reproducible:
Start vnc.so via xorg.conf and login from the vnc client

Steps to Reproduce:
1. Install vnc.so via xorg.conf
2. Login from vnc client
3. Start using the remote display and screen gets corrupted
  
Actual results:
Screen corruption

Expected results:
Clear display, no corruption

Additional info:
Always reproducbile.  Did not occur in FC2 or FC3.  My install is an upgrade
from FC3 (P4 HT 2.8, 512MB RAM, ASUS motherboard, onboard graphics)  Remote
machine is a windowsxp laptop

Comment 1 Tim Waugh 2005-07-04 16:09:05 UTC
Please show me a screen shot of the VNC viewer window, so that I can see what
sort of corruption is happening.

Comment 2 Srini 2005-07-08 14:56:03 UTC
Created attachment 116520 [details]
Screenshots of the corrupted screen as requested

Apologies for the delay.  As requested I have attached 3 screenshots of the
corrupted screen as displayed on the windows xp vnc viewer

Regards
Srini

Comment 3 Tim Waugh 2005-07-11 12:37:16 UTC
What does 'rpm -q vnc-server' say?

Comment 4 Srini 2005-07-11 15:50:23 UTC
vnc-server-4.1.1-10

Comment 5 Tim Waugh 2005-07-11 15:53:04 UTC
Hmm, wonder if this is related to RENDER.

Comment 6 Tim Waugh 2005-07-12 10:10:23 UTC
Please try with these packages:

ftp://people.redhat.com/twaugh/tmp/vnc-fc4

I have disabled the RENDER support.  Does that make the problem go away?

Comment 7 Srini 2005-07-12 16:43:55 UTC
Yes the problem goes away with the vnc-server-4.1.1-10.0.0.1 that I downloaded
from the ftp path above.  

Looks like this fixes it :-)

Comment 8 Tim Waugh 2005-07-14 12:19:57 UTC
The real fix would be to make RENDER support work.  However, I have spent some
time on this and discovered that OpenOffice.org can cause
Xvnc-with-RENDER-support to get into some sort of busy loop.

This RENDER stuff has taken too much time now, so I'm going to pull it out. :-(

Comment 9 Mike Cohler 2005-07-28 11:07:20 UTC
I had seen this problem also, and just wondered if you installed just the
vnc-server alone or this plus vnc ?  I presume that only installing the server
rpm did the trick ? 

I guess that the client machine did not need changing?

Did you simply run the rpm in using rpm -ivh .....rpm or did you do more than this ?

Thanks 
Mike


Comment 10 Srini 2005-07-28 15:14:40 UTC
No Change on client
Server - rpm -Uvh

Regards
Srini

Comment 11 Mike Cohler 2005-07-28 20:51:45 UTC
OK Thanks Srini

I wonder if this is going to be fixed upstream soon? and if so how soon it will
be in the normal updates (or test updates soon first)? Perhaps Tim might be able
to give us an idea of timescale for the fix to appear in the update rpms.

Mike

Comment 12 Mike Cohler 2005-07-30 10:10:43 UTC
I have now run some tests with the versions of the replacment RPMs quoted in
comment #6 above.  In this case both the server and the client machine are
running FC4 fully up to date. The server is running Gnome and the client KDE.

test 1) installed the vnc-server version vnc-server-4.1.1-10.0.0.1 on the server
machine

Tried to vnc in from the client running the stock version of vnc - it still had
the same screen corruption problems that were there before.

test 2) I now installed vnc-4.1.1-10.0.0.1 on the client machine and tried again.

Still the same.

test 3) had the modified version of both vnc and vnc-server on both server and
client machines.

Still not working and still the same screen corruption problem.

(As a matter of interest the same client running FC4 with the stock version of
vnc is able to vnc in to a different machine runing fc3 with up to date fc3
versions of vnc and vnc-server, and this presents no problems with screen
painting or any kind of corruption)

I have reverted to the stock versions of vnc and vnc-server on both machines and
now cannot use vnc on these machines until this problem is rectified.

Since this is a part of the system which I rely on I believe this needs to be
fixed quite urgently.

Thanks

Mike



Comment 13 Mike Cohler 2005-08-03 20:14:32 UTC
The new versions of the vnc and vnc-server DO indeed fix the problem - I think
that when I did the original checks I may not have re-started X after installing
the RPMs - I have done a new test installing both vnc and vnc-server (version
4.1.1-10.0.0.1) on both server and client and then re-started X on both machines.

Now vnc works perfectly without screen corruption at all.

So thanks Tim for the update rpms - I should have been more careful about
checking that I had re-started X before running vnc after the changes.

Great - everything golden again!

Comment 14 Peter Åstrand 2005-08-17 08:37:44 UTC
Created attachment 117823 [details]
Improved vncHooks.cc:vncHooksComposite that might solve this problem

Comment 15 Tim Waugh 2005-09-05 11:12:18 UTC
We'll look at RENDER again for FC6.

Comment 16 Adam Tkac 2006-11-08 12:09:14 UTC
(In reply to comment #14)
> Created an attachment (id=117823) [edit]
> Improved vncHooks.cc:vncHooksComposite that might solve this problem

Hmm, interesting solution. Please, could you tell me how can be your code
imported to vncHooks.cc?? (which class you want substitute...)



Comment 17 Peter Åstrand 2006-11-08 13:36:03 UTC
If I remember correctly, there's no vncHooks.cc:vncHooksComposite until you have
applied the RENDER patch. So, nothing should be substituted, but rather added. 

You might want to take a look at
http://vnc-tight.svn.sourceforge.net/viewvc/vnc-tight/trunk/unix/xc/programs/Xserver/vnc/vncHooks.cc?view=markup,
to see how the code is integrated into vncHooks.cc. 

I can confirm that this code is stable, at least in TightVNC: We are shipping it
in ThinLinc and we haven't had any RENDER problems in a long time. 

Comment 18 Adam Tkac 2006-11-18 17:15:40 UTC
definitely imported vncHooksComposite to vncserver code. Version 4.1.2-6.fc7 is
now avaliable


Note You need to log in before you can comment on or make changes to this bug.