Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162296 - kfmclient crashes after changing kdesktop wallpaper
Summary: kfmclient crashes after changing kdesktop wallpaper
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-02 00:51 UTC by Andrea Santilli
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 3.5.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-23 11:21:53 UTC


Attachments (Terms of Use)

Description Andrea Santilli 2005-07-02 00:51:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
After changing the wallpaper in KDE, when i run kfmclient the file selector seems frozen (only that, the rest of the window works ok). Moreover kfmclient closes itself after 2-3 seconds without any error message nor bug report dialog.
The problem seems to stay even after logout/login until i run konqueror, select some directory listing in the filesystem, close it and kfmclient works again.

Version-Release number of selected component (if applicable):
3.4.1-0.fc4.1

How reproducible:
Always

Steps to Reproduce:
1. In KDE, change kdesktop wallpaper
2. run kfmclient
3. file selector is frozen and the program closes itself after a few seconds
  

Additional info:

The problem stays even after relogging into kde.
i have to run konqueror, select some directory listing and kfmclient works good again.

Comment 1 Andrea Santilli 2005-07-02 20:33:53 UTC
I recently discovered this happens even with konqueror when in command line i do:
konqueror URL

I have done:
# konqueror ~

And this is the result:
*** glibc detected *** konqueror: double free or corruption (out): 0x092b3680 ***
======= Backtrace: =========
/lib/libc.so.6[0xc06424]
/lib/libc.so.6(__libc_free+0x77)[0xc0695f]
/usr/lib/libstdc++.so.6(_ZdlPv+0x21)[0x9a8669]
/usr/lib/kde3/konq_sound.so(_ZN9__gnu_cxx10__mt_allocISsNS_20__common_pool_policyINS_6__poolELb1EEEE10deallocateEPSsj+0x40)[0x5d5466e]
/usr/lib/kde3/konq_sound.so(_ZN19KonqSoundPlayerImpl9mimeTypesEv+0x259)[0x5d53c29]
/usr/lib/libkonq.so.4(_ZN18KonqIconViewWidget10slotOnItemEP13QIconViewItem+0x1f8)[0x62b958]
/usr/lib/libkonq.so.4(_ZN18KonqIconViewWidget9qt_invokeEiP8QUObject+0x14c)[0x62f43c]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QObject15activate_signalEP15QConnectionListP8QUObject+0xd1)[0x1055757]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN9QIconView6onItemEP13QIconViewItem+0x8d)[0x13fc21f]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN9QIconView22contentsMouseMoveEventEP11QMouseEvent+0x4d)[0x12322cb]
/usr/lib/libkonq.so.4(_ZN18KonqIconViewWidget22contentsMouseMoveEventEP11QMouseEvent+0xbf)[0x628449]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN11QScrollView22viewportMouseMoveEventEP11QMouseEvent+0x9f)[0x117d68f]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN11QScrollView11eventFilterEP7QObjectP6QEvent+0x19c)[0x117a6e4]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN9QIconView11eventFilterEP7QObjectP6QEvent+0x39)[0x122bdb7]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QObject16activate_filtersEP6QEvent+0x5a)[0x105527c]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QObject5eventEP6QEvent+0x35)[0x10552f1]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN7QWidget5eventEP6QEvent+0x26)[0x10937ec]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN12QApplication14internalNotifyEP7QObjectP6QEvent+0x97)[0xff0acd]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x6bb)[0xff1a2f]
/usr/lib/libkdecore.so.4(_ZN12KApplication6notifyEP7QObjectP6QEvent+0x1ef)[0x2db7a1]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN9QETWidget19translateMouseEventEPK7_XEvent+0x8ba)[0xf88146]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN12QApplication15x11ProcessEventEP7_XEvent+0x619)[0xf86901]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN10QEventLoop13processEventsEj+0x238)[0xf9aa08]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN10QEventLoop9enterLoopEv+0x94)[0x1009172]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN10QEventLoop4execEv+0x26)[0x1009096]
/usr/lib/qt-3.3/lib/libqt-mt.so.3(_ZN12QApplication4execEv+0x1f)[0xff0499]
/usr/lib/libkdeinit_konqueror.so(kdemain+0x4bd)[0x15cd6d]
/lib/libc.so.6(__libc_start_main+0xc6)[0xbb7de6]
konqueror[0x8048569]
======= Memory map: ========
00111000-001e1000 r-xp 00000000 03:06 1334417    /usr/lib/libkdeinit_konqueror.so
001e1000-001ea000 rwxp 000d0000 03:06 1334417    /usr/lib/libkdeinit_konqueror.so
001ea000-001f0000 r-xp 00000000 03:06 2713035    /usr/lib/libfam.so.0.0.0
001f0000-001f1000 rwxp 00006000 03:06 2713035    /usr/lib/libfam.so.0.0.0
001f1000-0021f000 r-xp 00000000 03:06 2713028    /usr/lib/libidn.so.11.5.8
0021f000-00221000 rwxp 0002d000 03:06 2713028    /usr/lib/libidn.so.11.5.8
00223000-00469000 r-xp 00000000 03:06 2713030    /usr/lib/libkdecore.so.4.2.0
00469000-00479000 rwxp 00246000 03:06 2713030    /usr/lib/libkdecore.so.4.2.0
00479000-0047c000 rwxp 00479000 00:00 0
0047e000-004d7000 r-xp 00000000 03:06 3668070    /usr/lib/libmng.so.1.0.0
004d7000-004da000 rwxp 00058000 03:06 3668070    /usr/lib/libmng.so.1.0.0
004da000-004dc000 r-xp 00000000 03:06 33719720  
/usr/X11R6/lib/X11/locale/lib/common/xlcDef.so.2
004dc000-004dd000 rwxp 00001000 03:06 33719720  
/usr/X11R6/lib/X11/locale/lib/common/xlcDef.so.2
004dd000-00524000 r-xp 00000000 03:06 169275927 
/usr/lib/kde3/plugins/styles/thinkeramik.so
00524000-00527000 rwxp 00046000 03:06 169275927 
/usr/lib/kde3/plugins/styles/thinkeramik.so
00527000-00530000 r-xp 00000000 03:06 252111969 
/usr/lib/qt-3.3/plugins/inputmethods/libqimsw-multi.so
00530000-00531000 rwxp 00008000 03:06 252111969 
/usr/lib/qt-3.3/plugins/inputmethods/libqimsw-multi.so
00531000-00533000 r-xp 00000000 03:06 1686661    /usr/lib/libpcreposix.so.0.0.0
00533000-00534000 rwxp 00001000 03:06 1686661    /usr/lib/libpcreposix.so.0.0.0
00535000-0054f000 r-xp 00000000 03:06 51868689   /lib/ld-2.3.5.so
0054f000-00550000 r-xp 00019000 03:06 51868689   /lib/ld-2.3.5.so
00550000-00551000 rwxp 0001a000 03:06 51868689   /lib/ld-2.3.5.so
00551000-00562000 r-xp 00000000 03:06 254870011 
/usr/lib/qt-3.3/plugins/inputmethods/libiiimqcf.so
00562000-00563000 rwxp 00011000 03:06 254870011 
/usr/lib/qt-3.3/plugins/inputmethods/libiiimqcf.so
00563000-00589000 r-xp 00000000 03:06 2309630    /usr/lib/libiiimcf.so.3.0.0
00589000-0058c000 rwxp 00025000 03Alarm clock


Comment 2 Andrea Santilli 2005-07-02 20:43:08 UTC
So it looks like a problem with audio preview...
It could be a problem with konqueror itself but i have to say that im sharing my
soundcard among processes with alsa. so it could even be an alsa bug...

Comment 3 Ngo Than 2005-07-04 09:00:06 UTC
i'm not able to reproduce this crash here. Could you please install the
kdelibs/kdebase debuginfo packages and try to get the backtrace again. Thanks


Note You need to log in before you can comment on or make changes to this bug.