Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162269 - Kernel hang during boot before init starts (ACPI/PCI/IRQ related, happens at IDE probing time)
Summary: Kernel hang during boot before init starts (ACPI/PCI/IRQ related, happens at ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-01 20:27 UTC by Øyvind Stegard
Modified: 2015-01-04 22:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 23:33:02 UTC


Attachments (Terms of Use)
Specs of machine where kernel hangs (deleted)
2005-07-01 20:29 UTC, Øyvind Stegard
no flags Details
Discription of my computer (deleted)
2005-07-02 18:41 UTC, Carl Parrish
no flags Details
acpi-dont-accept-0-as-valid-irq.patch (deleted)
2005-07-03 19:01 UTC, Øyvind Stegard
no flags Details | Diff

Description Øyvind Stegard 2005-07-01 20:27:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The kernel hangs during boot on my Compaq AMD Athlon XP laptop (Presario 920EA).
The hang occurs during IDE probing:
-- kernel output start --
...
...
ACPI: PCI Interrupt 0000:00:10.0[A]: no GSI - using IRQ 0
ALI15X3: chipset revision 196
ALI15X3: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x8080-0x8087, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x8088-0x808f, BIOS settings: hdc:pio, hdd:pio
-- !! KERNEL HANGS HERE !!, kernel output end --

ALI IDE controller regressions ? kernel-2.6.12-1.1385_FC4 boots just fine on the very same laptop.


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1387_FC4

How reproducible:
Always

Steps to Reproduce:
1. Try to boot kernel on my laptop.

  

Actual Results:  The kernel hung.

Expected Results:  I expected it to boot, this laptop has never previously had problems with Fedora kernels.

Additional info:

Specs will be attached.

Comment 1 Øyvind Stegard 2005-07-01 20:29:11 UTC
Created attachment 116261 [details]
Specs of machine where kernel hangs

Need more ? Please ask, and I shall post it.

Comment 2 Stephen Moehle 2005-07-02 06:21:04 UTC
Exact same issue here with kernel 2.6.12-1.1387_FC4 on an HP Athlon XP laptop
(Pavillion ze4560us). Same boot messages with ALI15X3 chipset before hang as well.

Comment 3 Carl Parrish 2005-07-02 18:27:57 UTC
I seem to be having the same problem on my desktop. Kernel 2.6.12-1.1387_FC4, no
problems with 2.6.11-1.1369_FC4

[<c0100274>] init +0x0/0xfc
[<c0103c03>] common_interrupt +0x1a/0x20
[<c010101a>] default_idle +0x0/0x29
[<c0101040>] default_idle +0x26/0x29
[<c042170a>] cpu_idle +0x34/0x4c
[<c042170a>] start_kernel +0x15d/0x1b7
[<c04212f7>] unknown_bootoption +0x0/0x1b6

This is what my screen says when it gets stuck. 

Comment 4 Carl Parrish 2005-07-02 18:41:03 UTC
Created attachment 116293 [details]
Discription of my computer

just the output of  lspci

Comment 5 Øyvind Stegard 2005-07-03 16:20:30 UTC
I just tested 2.6.12.2 vanilla, and it has the exact same problem. Thus the
problem has probably been introduced with this version. 2.6.12.2 is the only
change from 1.1385_FC4 to 1.1387_FC4, according to RPM changelog.

Will try with vanilla 2.6.13-rc1.

Comment 6 Øyvind Stegard 2005-07-03 17:14:49 UTC
(In reply to comment #5)
> I just tested 2.6.12.2 vanilla, and it has the exact same problem. Thus the
> problem has probably been introduced with this version. 2.6.12.2 is the only
> change from 1.1385_FC4 to 1.1387_FC4, according to RPM changelog.
> 
> Will try with vanilla 2.6.13-rc1.
Doesn't work either, same problem 8(.

Comment 7 Øyvind Stegard 2005-07-03 18:41:36 UTC
> (In reply to comment #5)
> > I just tested 2.6.12.2 vanilla, and it has the exact same problem. Thus the
> > problem has probably been introduced with this version. 2.6.12.2 is the only
> > change from 1.1385_FC4 to 1.1387_FC4, according to RPM changelog.
> > 
> > Will try with vanilla 2.6.13-rc1.
> Doesn't work either, same problem 8(.
OK, I got i working with 2.6.13-rc1. Seems this patch was needed:
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=44f8e1a20cf3afe10a3744bd9317808a39a242bb
(ACPI/IRQ stuff, one line fix)
I applied it to 2.6.13-rc1, and it now boots. 

I will now try this patch isolated on 2.6.12-1.1387_FC4, and see if it works,
since 2.6.13-rc1 had other problems with FC4 that I'm not willing to deal with,
right now.


Comment 8 Øyvind Stegard 2005-07-03 18:58:56 UTC
(In reply to comment #7)
> I will now try this patch isolated on 2.6.12-1.1387_FC4, and see if it works,
> since 2.6.13-rc1 had other problems with FC4 that I'm not willing to deal with,
> right now.
OK, confirmed, 2.6.12-1.1387_FC4 boots on my laptop after applying the above
patch I mentioned in comment #7. I'll settle for this right now, and leave it up
the bugzilla/kernel maintainers to change bug status, when it's officially fixed
(the patch comes from linux-2.6.13-rc1-git5 upstream).

For those who want to recompile the 1.1387_FC4 kernel, I'm going to add the
patch as an attachment.

Ãyvind.

Comment 9 Øyvind Stegard 2005-07-03 19:02:00 UTC
Created attachment 116312 [details]
acpi-dont-accept-0-as-valid-irq.patch

Patch that fixes problem (on my laptop, at least).

Comment 10 Nathan G. Grennan 2005-07-05 18:12:38 UTC
pci=noacpi works on my laptop that has the problem with not booting
2.6.12-1.1387_FC4, where as 2.6.11-1.1369_FC4 worked without it.

Comment 11 Øyvind Stegard 2005-07-05 18:27:13 UTC
(In reply to comment #10)
> pci=noacpi works on my laptop that has the problem with not booting
> 2.6.12-1.1387_FC4, where as 2.6.11-1.1369_FC4 worked without it.
Yep, seems like this is the easiest work-around, without having to disable ACPI
entirely (or recompiling w/patch). 

Comment 12 Dave Jones 2005-07-07 21:54:24 UTC
*** Bug 162321 has been marked as a duplicate of this bug. ***

Comment 13 Dave Jones 2005-07-15 21:11:15 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 14 Øyvind Stegard 2005-07-15 22:18:25 UTC
(In reply to comment #13)
2.6.12-1.1398_FC4 boots just fine. 

The problem disappeared after the update to 2.6.12-1.1390_FC4. As far as I'm
concerned, this bug is fixed.

Comment 15 Carl Parrish 2005-07-17 23:36:10 UTC
2.6.12-1.1390_FC4 is working fine for me. 


Note You need to log in before you can comment on or make changes to this bug.