Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162261 - Unable to see Japanese characters on documents
Summary: Unable to see Japanese characters on documents
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-01 19:32 UTC by Robert Marcano
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.9.116-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-10 15:14:23 UTC


Attachments (Terms of Use)
en_US based screenshot (deleted)
2005-07-01 19:36 UTC, Robert Marcano
no flags Details
ja_JP based screenshot (deleted)
2005-07-01 19:37 UTC, Robert Marcano
no flags Details
Test document (deleted)
2005-07-01 19:37 UTC, Robert Marcano
no flags Details
sample code (deleted)
2005-07-08 13:56 UTC, Caolan McNamara
no flags Details

Description Robert Marcano 2005-07-01 19:32:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Running oo under LANG=en_US.UTF-8 is not posible to see Japanese characters in the documents, it does not matter if the document previously had them or if they are typed using the iiim imput method.


Version-Release number of selected component (if applicable):
1.9.112-1.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1. run openoffice under LANG=en_US.UTF-8 locale
2. Open a document with hiragana characters
  

Actual Results:  Hiragana characters are replaced with a square icon (attaching screenshot)

Expected Results:  Font must be displayed as happened on openoffice 1.1.x on FC3 woth the japanese fonts installed

Additional info:

When openoffice is executed within a console, the following message is printed

--- Couldn't get FontFamily for 'MiscFixed'

and everytimes the mouse hover over the location of the japanese characters the message is printed again.

Opening the document under LANG=ja_JP.UTF-8, shows everything correctly:

Related intalled packages:

openoffice.org-pyuno-1.9.112-1.1.0.fc4
openoffice.org-langpack-es-1.9.112-1.1.0.fc4
openoffice.org-draw-1.9.112-1.1.0.fc4
openoffice.org-graphicfilter-1.9.112-1.1.0.fc4
openoffice.org-javafilter-1.9.112-1.1.0.fc4
openoffice.org-writer-1.9.112-1.1.0.fc4
openoffice.org-core-1.9.112-1.1.0.fc4
openoffice.org-impress-1.9.112-1.1.0.fc4
openoffice.org-math-1.9.112-1.1.0.fc4
openoffice.org-langpack-ja_JP-1.9.112-1.1.0.fc4
openoffice.org-calc-1.9.112-1.1.0.fc4
openoffice.org-xsltfilter-1.9.112-1.1.0.fc4
fonts-japanese-0.20050222-3

Comment 1 Robert Marcano 2005-07-01 19:36:27 UTC
Created attachment 116255 [details]
en_US based screenshot

Notice the squares

Comment 2 Robert Marcano 2005-07-01 19:37:16 UTC
Created attachment 116256 [details]
ja_JP based screenshot

Notice the characters displayed correctly

Comment 3 Robert Marcano 2005-07-01 19:37:52 UTC
Created attachment 116257 [details]
Test document

Comment 4 Caolan McNamara 2005-07-04 08:10:52 UTC
caolanm->dcbw: that's a bit odd seeing as the difference on locales should only
be what fonts and fallbacks are the default for a given CTL/CJK/Western and once
a document is created it's only fontfallback and surely the new fontconfig magic
should kick in giving something visible for CJK characters in all locales.

Comment 5 Caolan McNamara 2005-07-08 13:56:18 UTC
Created attachment 116518 [details]
sample code

The attached code demonstrates the problem, with locale en_US it give me "Luxi
Sans", with locale ja_JP it gives me "Kochi Gothic"

Comment 6 Caolan McNamara 2005-07-08 16:07:07 UTC
nuisance, it doesn't work in en_US because fontconfig gives a substition of a
bitmap font during glyph substitution which ooo rejected from fontconfig for
OOo's list of acceptable fonts. The solution I see is at fontmanager to collect
the fonts from fontconfig which OOo allows and create a FcConfig of them and use
that FcConfig when substituting in vcl at a later date.

It works under ja_JP because at this level there is no encoding available for
the font, so fontconfig uses the default locale and in ja_JP a font gets
returned which OOo does know about and which does have the glyphs needed later,
but under en_US it's a different one which doesn't have the glphys needed later
and so the glyph substition gets underway which leads to {first paragraph}

Comment 7 Caolan McNamara 2005-07-08 16:22:38 UTC
oops!, didn't mean to reassign

Comment 8 Caolan McNamara 2005-07-08 16:32:35 UTC
added a fix to build, should be in 1.9.115-3

Comment 9 Caolan McNamara 2005-07-10 15:14:23 UTC
Fixed in 1.9.116-1 rawhide, will update for fc4 soon


Note You need to log in before you can comment on or make changes to this bug.