Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162242 - rpm --import with proxy fails with assertion error
Summary: rpm --import with proxy fails with assertion error
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-01 12:43 UTC by Marius Andreiana
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-05 11:32:31 UTC


Attachments (Terms of Use)

Description Marius Andreiana 2005-07-01 12:43:18 UTC
rpm --httpproxy $http_proxy --import
http://download.fedora.redhat.com/pub/fedora/linux/extras/RPM-GPG-KEY-Fedora-Extras
error:
http://download.fedora.redhat.com/pub/fedora/linux/extras/RPM-GPG-KEY-Fedora-Extras:
import read failed(-1).
rpmk: url.c:103: XurlFree: Assertion `u && u->magic == 0xd00b1ed0' failed.
Aborted

Reproducibility: 100%

Comment 1 Jeff Johnson 2005-07-13 10:18:18 UTC
The option --httpproxy is almost certainly not what you want, what's implemented is
a TIS proxy from ~1998.

Comment 2 Jeff Johnson 2006-08-05 11:32:31 UTC
Since the issue of rpm being network aware is controversial and unlikely to change even gradually
this decade, I suggest that you use alternative means of transport that handle modern proxies,
and then import as a secondary step.

DEFERRED until the rpm development/upgrade glaciers melt in the year 2020 ...


Note You need to log in before you can comment on or make changes to this bug.