Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162235 - xcscope.el not found by emacs/xemacs
Summary: xcscope.el not found by emacs/xemacs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: cscope
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Neil Horman
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-01 08:04 UTC by David Juran
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 12:05:56 UTC


Attachments (Terms of Use)

Description David Juran 2005-07-01 08:04:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.7.8-1.1.3.1

Description of problem:
xcscope.el is not located on a path identified by load-path and can therefore not be found by emacs/xemacs

Version-Release number of selected component (if applicable):
cscope-15.5-9.RHEL3

How reproducible:
Always

Steps to Reproduce:
1. add (require'xcscope) to ~/.emacs as outlined in tha man page for xcscope
2. note that cscope is still not available in emacs/xemacs
  

Additional info:

Comment 1 Frank Ch. Eigler 2005-07-04 15:01:28 UTC
Good point.  xcscope.el should be installed into /usr/share/emacs/site-lisp.

Comment 2 Neil Horman 2005-07-05 17:36:38 UTC
Actually, xcscope.el should be in /usr/share/emacs/site-lisp for emacs and in
/usr/share/xemacs/site-packages/lisp for xemacs, and it appears in both places
for me (as the result of the triggerin scripts in the spec file.  When I run
emacs or xemacs, adding the require line in the .emacs file works just fine for
me (I am able to access the cscope meta-commands in the buffer.  This kind of
smells like a bad .emacs->.xemacs conversion to me.  Or perhaps, your site
configuarion has changed the default load path to look for cscope is someplace
other than where it is installed?  You'd be able to tell by stracing the xemacs
start up.  If the xcscope.el file isn't getting found, we'll see where its
looking on that.


Comment 3 David Juran 2005-07-06 12:05:56 UTC
OK, I think I found the error now. 
Previously we had cscope from Fedora Extras installed. This package didn't
contain any triggers but had instead placed xscope.el in
/usr/share/emacs/site-lisp. Then when cscope got included in RHEL3, we ran
'up2date -u cscope' to update to the RHEL3 version of cscope. And here I guess
things happened in the wrong order so that the links were never made.


Note You need to log in before you can comment on or make changes to this bug.