Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162224 - OpenOffice.org Writer fails to export Scandinavian characters to PDF
Summary: OpenOffice.org Writer fails to export Scandinavian characters to PDF
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 23:37 UTC by Jarkko
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.0.0-3.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-25 11:01:20 UTC


Attachments (Terms of Use)
sample document which causes the problem on export to pdf (deleted)
2005-07-15 16:30 UTC, Jarkko
no flags Details
1.9.117-1, but I have Thorndale as Times New Roman fallback (deleted)
2005-07-15 17:32 UTC, Caolan McNamara
no flags Details

Description Jarkko 2005-06-30 23:37:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:
After upgrade to 1.9.112-1.1.0.fc4 OpenOffice.org Writer stopped from exporting Scandinavian characters (like '�') to PDF. Some fonts work, but for example "Times New Roman", the most used one, does not export '�' characters to the PDF document. I see only blank spaces in place of the '�' characters.

Version-Release number of selected component (if applicable):
openoffice.org-writer-1.9.112-1.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to openoffice.org-writer-1.9.112-1.1.0.fc4
2. Write a document which has '�' characters and use "Times New Roman" as font
3. Export to PDF
  

Actual Results:  All '�' characters are missing (blank spaces).

Expected Results:  All '�' characters should have been there, like they were with the earlier version of OpenOffice.org Writer.

Additional info:

Basically, the generated PDF document is useless because of this problem as all the Scandinavian chanracters are missing from it.

--> Loss of data from the PDF documents --> High severity :)

(Although this is not really funny as all...)

Comment 1 Jarkko 2005-07-01 00:14:13 UTC
Bugzilla did not get the letter 'ä' correctly. :)

Anyway, just to confirm; I just downgraded writer and core to 1.9.104-2 (other
packages are still the newer ones) and now the PDF export works correctly.

So the problem is indeed in the latest version only. Either within core or
writer packages.

Comment 2 Caolan McNamara 2005-07-01 07:54:50 UTC
caolanm->dcbw: presumably fontconfig changes...

Comment 3 Dan Williams 2005-07-05 15:39:12 UTC
Presumably, I'll have to check if the pdf_writer font sub stuff needs to go
through Fontconfig too.

Comment 4 Caolan McNamara 2005-07-15 15:11:55 UTC
I made a few more mods to the fontconfig stuff in 1.9.117-1 which might not
affect this, but then again it might be magically cured. Can you check that
version, or if not attach a sample document which causes the problem on export
to pdf

Comment 5 Jarkko 2005-07-15 16:30:13 UTC
Created attachment 116807 [details]
sample document which causes the problem on export to pdf

Comment 6 Caolan McNamara 2005-07-15 17:32:54 UTC
Created attachment 116813 [details]
1.9.117-1, but I have Thorndale as Times New Roman fallback


Note You need to log in before you can comment on or make changes to this bug.