Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162219 - FC4 release notes should mention how to use gcc32
Summary: FC4 release notes should mention how to use gcc32
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: release-notes
Version: devel
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Release Notes Tracker
QA Contact: Tammy Fox
URL:
Whiteboard:
: 162217 (view as bug list)
Depends On:
Blocks: fc-relnotes-traqr
TreeView+ depends on / blocked
 
Reported: 2005-06-30 21:36 UTC by Julius Smith
Modified: 2007-04-18 17:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-22 21:30:52 UTC


Attachments (Terms of Use)

Description Julius Smith 2005-06-30 21:36:10 UTC
Description of problem:
Many tarballs from the Web do not compile because gcc 4.0 is so new (and strict).

I suggest adding the following info to the FC4 release notes in the "Caveats"
subsection of section "6.3.1. GCC Compiler Collection"

* When compiling source that has not yet been upgraded to gcc-4.0 compatibility,
the earlier gcc-3.2 compiler can be used.  It can be installed via

yum install compat-gcc-32

and many makefiles can be invoked with "CC=gcc32" to use it.  Also, many
INSTALLs can be configured to use it as follows:

./configure --cc=gcc32

Additional info:

From: Rahul Sundaram <sundaram@redhat.com>
Reply-To: For users of Fedora Core releases <fedora-list@redhat.com>
To: jos@ccrma.stanford.edu, For users of Fedora Core releases
<fedora-list@redhat.com>
Date: Jun 30, 2005 2:11 PM
Subject: Re: FC4 good new tech, bad legacy support

Julius Smith wrote:

>On 6/30/05, Rahul Sundaram <sundaram@redhat.com> wrote:
>
>
>>If the software doesnt work with either gcc 3.2 or gcc 4.x then its
>>probably broken. GCC 4.x is there as the primary compiler. compat-gcc-32
>>for legacy support. I am not sure what else could be done better here.
>>any ideas?
>>
>>
>
>This has  been working very well for me.  However, it took me a while
>to figure out that I needed
>
>yum install compat-gcc-32
>./configure --cc=gcc32
>
>It would have been nice to have this info in the FC4 release notes
>near then end of the section "6.3.1. GCC Compiler Collection", or
>perhaps in the "Caveats" subsection.
>
>Julius
>
>
>
great idea. Kindly file it against fedora-docs and we will have a
release notes errata
- Hide quoted text -

regards
Rahul

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: http://www.redhat.com/mailman/listinfo/fedora-list

Comment 1 Julius Smith 2005-06-30 21:43:09 UTC
This is essentially a duplicate of Bug 162217 (a couple of typos were fixed in
this version). I apologize for the accidental double posting.

Comment 2 Karsten Wade 2005-06-30 21:47:15 UTC
reassigning to release notes tracker

Comment 3 Karsten Wade 2005-06-30 21:47:56 UTC
*** Bug 162217 has been marked as a duplicate of this bug. ***

Comment 4 Paul W. Frields 2005-06-30 22:11:26 UTC
If we do this, should we include also compat-lib{gcc,stdc++}-296?  This provides
(IIRC) compatibility for Red Hat Linux 7.3 apps.

Comment 5 Julius Smith 2005-07-01 02:44:56 UTC
For that, how about a new section of the release notes entitled "Backward
Compatibility", organized in reverse-chronological order?  In that case, the
"Caveats" subsection of Section 6.3.1 could simply point to the beginning that
section.  I would probably insert it as a new Section 7.

Comment 6 Dawid Gajownik 2005-07-11 08:22:06 UTC
Please don't forget about CXX variable. Some code does not also compile with g++
from gcc-c++-4.0.0 package (for example tvtime รข
http://sourceforge.net/tracker/index.php?func=detail&aid=1230713&group_id=64301&atid=506987).

Comment 7 Tommy Reynolds 2005-07-19 04:21:02 UTC
Added to CVS.  Close this one.

Comment 8 Karsten Wade 2005-07-22 20:45:19 UTC
Updated content a bit and included this in a recent publishing of the online
release notes:

http://fedora.redhat.com/docs/release-notes/fc4/errata/

Comment 9 Rahul Sundaram 2005-08-29 10:03:13 UTC

The information above seems to be misleading. The errata does not include a
section on backward compatibility. If an errata for this purpose is deemed to be
unimportant, We should make this a point for the subsequent versions


Note You need to log in before you can comment on or make changes to this bug.