Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162217 - FC4 release notes should mention how to use gcc32
Summary: FC4 release notes should mention how to use gcc32
Keywords:
Status: CLOSED DUPLICATE of bug 162219
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: release-notes
Version: devel
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Wade
QA Contact: Tammy Fox
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 21:26 UTC by Julius Smith
Modified: 2007-04-18 17:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-30 21:47:44 UTC


Attachments (Terms of Use)

Description Julius Smith 2005-06-30 21:26:50 UTC
Description of problem:
Many tarballs from the Web do not compile because gcc 4.0 is so new (and strict).

I suggest adding the following info to the FC4 release notes in the "Caveats"
subsection of section "6.3.1. GCC Compiler Collection", or

* When compiling source that has not yet been upgraded to gcc-4.0 compatibility,
the early gcc-3.2 compiler can be used.  It can be installed via

yum install compat-gcc-32

and many makefiles can be invoked with "CC=gcc32" to use it.  Also, many
INSTALLs can be configured to use it as follows:

./configure --cc=gcc32

Additional info:

From: Rahul Sundaram <sundaram@redhat.com>
Reply-To: For users of Fedora Core releases <fedora-list@redhat.com>
To: jos@ccrma.stanford.edu, For users of Fedora Core releases
<fedora-list@redhat.com>
Date: Jun 30, 2005 2:11 PM
Subject: Re: FC4 good new tech, bad legacy support

Julius Smith wrote:

>On 6/30/05, Rahul Sundaram <sundaram@redhat.com> wrote:
>
>
>>If the software doesnt work with either gcc 3.2 or gcc 4.x then its
>>probably broken. GCC 4.x is there as the primary compiler. compat-gcc-32
>>for legacy support. I am not sure what else could be done better here.
>>any ideas?
>>
>>
>
>This has  been working very well for me.  However, it took me a while
>to figure out that I needed
>
>yum install compat-gcc-32
>./configure --cc=gcc32
>
>It would have been nice to have this info in the FC4 release notes
>near then end of the section "6.3.1. GCC Compiler Collection", or
>perhaps in the "Caveats" subsection.
>
>Julius
>
>
>
great idea. Kindly file it against fedora-docs and we will have a
release notes errata
- Hide quoted text -

regards
Rahul

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: http://www.redhat.com/mailman/listinfo/fedora-list

Comment 1 Karsten Wade 2005-06-30 21:47:44 UTC

*** This bug has been marked as a duplicate of 162219 ***


Note You need to log in before you can comment on or make changes to this bug.