Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162211 - [RFE] New up2date command-line options
Summary: [RFE] New up2date command-line options
Keywords:
Status: CLOSED DUPLICATE of bug 162210
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 20:45 UTC by Brian Long
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-30 20:47:56 UTC


Attachments (Terms of Use)

Description Brian Long 2005-06-30 20:45:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040929

Description of problem:
I have developed a small patch to up2date which I would like product management to consider for inclusion in an official up2date errata.  The patch enables 3 new command-line options which are useful to all users of up2date.  These options are useful in enabling a single machine to be able to pull down RHN updates for multiple RHEL releases across multiple platforms.


Version-Release number of selected component (if applicable):
up2date-4.4.5.6-2

How reproducible:
Always

Steps to Reproduce:
New command-line options:
  
1) --downloadall: This option enables the retrieveOnly flag, but sets pkgList to the entire list of packages available in a channel.  It requires the --channel option as well.

2) --systemid: This option overrides the location of the systemid file which is used when connecting to RHN.  I can have 4 systemid files (systemid-as4-i386, systemid-as4-x86_64, systemid-as3-i386, systemid-as3-x86_64) and switch between them at will on a single machine.  Of course, on my RHEL 4 machine, I have to use the --upgrade-to-release 3AS flag in order to connect to the RHEL 3 channels, but as long as my systemid files are legitimate, this works like a charm.

3) --quiet: This option currently affects the up2dataBatch.py run method.  Typically, wrapperUtils.printVerboseList is always called which prints the entire channel contents (when used with --downloadall).  This new option disables the printVerboseList.  It also disables printing the # marks when each package is downloaded in getPackages.

Examples (all run on RHEL 4 i386 host):
1) Download all RHEL 4 i386 updates
up2date --channel rhel-i386-as-4 --downloadall --systemid /var/tmp/systemid-as4-i386 --tmpdir /auto/linux/sandbox/brilong/up2date-download/rhel-i386-as-4 --force --quiet

2) Download all RHEL 4 x86_64 updates
up2date --channel rhel-x86_64-as-4 --downloadall --systemid /var/tmp/systemid-as4-x86_64 --tmpdir /auto/linux/sandbox/brilong/up2date-download/rhel-x86_64-as-4 --force --quiet --arch x86_64-redhat-linux

3) Download all RHEL 3 i386 updates
up2date --channel rhel-i386-as-3 --downloadall --systemid /var/tmp/systemid-as3-i386 --tmpdir /auto/linux/sandbox/brilong/up2date-download/rhel-i386-as-3 --upgrade-to-release 3AS --force --quiet

4) Download all RHEL 3 x86_64 updates
up2date --channel rhel-x86_64-as-3 --downloadall --systemid /var/tmp/systemid-as3-x86_64 --tmpdir /auto/linux/sandbox/brilong/up2date-download2/rhel-x86_64-as-3 --upgrade-to-release 3AS --quiet --arch x86_64-redhat-linux

Additional info:

Comment 1 Brian Long 2005-06-30 20:47:56 UTC

*** This bug has been marked as a duplicate of 162210 ***


Note You need to log in before you can comment on or make changes to this bug.