Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162197 - [PATCH] Intel e1000 timeout problems with jumbo frames
Summary: [PATCH] Intel e1000 timeout problems with jumbo frames
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora Legacy
Classification: Retired
Component: kernel
Version: fc2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fedora Legacy Bugs
QA Contact:
URL:
Whiteboard: DEFER
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 19:09 UTC by Bryan Wann
Modified: 2007-04-18 17:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-13 14:31:12 UTC


Attachments (Terms of Use)
Mallikarjuna Chilakala's workaround for Intel 82546 errata 10, Tx descriptor having more than 2015 bytes (deleted)
2005-06-30 19:11 UTC, Bryan Wann
no flags Details | Diff
Mallikarjuna Chilakala's e1000 patch to correct writing across 64k boundary on 8254x chips due to errata 23 (deleted)
2005-06-30 19:13 UTC, Bryan Wann
no flags Details | Diff

Description Bryan Wann 2005-06-30 19:09:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Two patches I am submitting that fixes a timeout problem using jumbo frames with the e1000 driver and Intel 8254x-based gigabit NICs.  These were originally posted to the netdev list by Mallikarjuna Chilakala to completely upgrade the e1000 driver from 5.5.4-k2 to 6.0.54.  I am attaching the two patches that specifically address the timeout problem, avoiding introducing any new features.

Patch 1:
  http://marc.theaimsgroup.com/?l=linux-netdev&m=111462657412976&w=2

Implement a workaround for 82546 errata 10 --  first Tx descriptor
cannot have more than 2015 byte of data in it or it could hang the
transmitter.

Patch 2:
  This patch is select parts of the original patch posted to the netdev list that relate to the jumbo frames timeout issue:
  http://marc.theaimsgroup.com/?l=linux-netdev&m=111474482513945&w=2

First rev 82545 and 82546 need to not allow any memory
write location to cross 64k boundary due to errata 23

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install kernel-2.6.10-1.771 with the 5.5.4-k2-NAPI e1000 driver
2.  Bring up a bond interface with two gigabit interfaces with MTU=9000
3.  Pass 100-200Mbit/s of jumbo frames traffic through the bond interface
  

Actual Results:  After several minutes, the network interface times out causing a brief (1-2 second) network pause.  Repeats itself every 5 to 30 minutes.

kernel: NETDEV WATCHDOG: eth0: transmit timed out 

Expected Results:  No timeouts, smooth networking

Additional info:

Comment 1 Bryan Wann 2005-06-30 19:11:30 UTC
Created attachment 116180 [details]
Mallikarjuna Chilakala's workaround for Intel 82546 errata 10, Tx descriptor having more than 2015 bytes

Comment 2 Bryan Wann 2005-06-30 19:13:34 UTC
Created attachment 116181 [details]
Mallikarjuna Chilakala's e1000 patch to correct writing across 64k boundary on 8254x chips due to errata 23

Comment 3 Marc Deslauriers 2005-07-31 00:24:12 UTC
Did this make it into a more recent upstream kernel?

Comment 4 Pekka Savola 2005-11-16 13:28:40 UTC
This doesn't seem to be important enough to fix just on its own, so mark it DEFER.


Note You need to log in before you can comment on or make changes to this bug.