Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162173 - Some tar options are not working
Summary: Some tar options are not working
Keywords:
Status: CLOSED DUPLICATE of bug 161627
Alias: None
Product: Fedora
Classification: Fedora
Component: tar
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 16:22 UTC by Alberto Ferrante
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-01 07:36:16 UTC


Attachments (Terms of Use)

Description Alberto Ferrante 2005-06-30 16:22:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The --exclude, --exclude-from, and -N (and maybe others) options do not work with this version of tar.

Version-Release number of selected component (if applicable):
tar-1.15.1-5.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.type 'tar cvf destfile.tar sourcedir --exclude file_to_exclude
2.
3.
  

Actual Results:  The tar file is created, but file_to_exclude is not excluded from processing. An error is reported as '--exclude file_to_exclude' were interpreted as filenames. The same happens with the other non-working options.

Expected Results:  file_to_exclude should have been excluded from processing; no error messages.

Additional info:

Downgrading to tar-1.14-4 (from FC3) solves the problem.

Comment 1 Peter Vrabec 2005-07-01 07:36:16 UTC

*** This bug has been marked as a duplicate of 161627 ***


Note You need to log in before you can comment on or make changes to this bug.