Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162154 - /etc/issue and /etc/issue.net are moved to .rpmsave and replaced
Summary: /etc/issue and /etc/issue.net are moved to .rpmsave and replaced
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: redhat-release
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Mike McLean
QA Contact:
URL:
Whiteboard:
: 207603 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 13:37 UTC by Jim Perrin
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0149
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-13 23:03:16 UTC


Attachments (Terms of Use)

Description Jim Perrin 2005-06-30 13:37:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050523 CentOS/1.0.4-1.4.1.centos4 Firefox/1.0.4

Description of problem:
when updating, up2date fails to update systems where /etc/issue and /etc/issue.net have been modified. When the update is forced, /etc/issue and /etc/issue.net are moved to .rpmsave files and replaced. 

The offending lines in the spec file are:
%config %attr(0644,root,root) /etc/issue
%config %attr(0644,root,root) /etc/issue.net

These should be modified to read:
%config(noreplace) %attr(0644,root,root) /etc/issue
%config(noreplace) %attr(0644,root,root) /etc/issue.net



Version-Release number of selected component (if applicable):
redhat-release-4ES-2.4

How reproducible:
Always

Steps to Reproduce:
1. Create custom /etc/issue and /etc/issue.net
2. Update redhat-release package
3. verify /etc/issue is no longer your file
  

Actual Results:  /etc/issue{issue.net} contains default text

Expected Results:  should contain custom text with .rpmnew created in /etc/

Additional info:

For systems where policy requires a message to be displayed prior to any login attempts, this becomes a gotcha for administrators to check up on.

Comment 1 Lee Whatley 2005-07-01 13:32:17 UTC
This problem also exists in RHEL v3.  Granted, it's not that big of a deal, but
it is an annoyance for those of us with custom text in our /etc/issue files.

Comment 3 Jim Perrin 2006-01-04 15:58:02 UTC
Any new word on this one? Been a while and no response.....

Comment 5 Mike McLean 2006-01-04 16:20:04 UTC
The fix should be in the current U3 beta.
https://rhn.redhat.com/network/software/packages/details.pxt?pid=334491

HOWEVER, because of the triggers that exist in the old redhat-release RPMs,
the fix will not take effect when the package is first updated. For this update
the previously customized files will get moved to /etc/issue.rpmsave and
/etc/issue.net.rpmsave. You will have to reapply those customizations one
time. After that, further upgrades will work as expected.

Comment 6 Jim Perrin 2006-01-04 16:53:25 UTC
Excellent. Thanks

Comment 7 Daniel Riek 2006-03-13 23:03:16 UTC
Copying from (private) bug#174526:

An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0149.html

Comment 8 Mike McLean 2006-10-10 15:18:11 UTC
*** Bug 207603 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.