Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162149 - Installer Crashes when partioning hard drive
Summary: Installer Crashes when partioning hard drive
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 11:41 UTC by Seb Payne
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-08 18:32:43 UTC


Attachments (Terms of Use)

Description Seb Payne 2005-06-30 11:41:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050405 Firefox/1.0 (Ubuntu package 1.0.2)

Description of problem:
When running the Anaconda Fedora Core 4 installation, either Graphical or Text, it crashes out as soon as it tries to partition the drive. But, if I then re-run the installation, it works fine. 

It is removing previous Linux partitions and replacing them with LVM.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start the Fedora Core Install process
2. Follow the install process (Remove All partions, Personal Software selection)
3. Start the actual Anaconda installation process
  

Actual Results:  Traceback (most recent call last):
 File "/usr/local/bin/anaconda, line 1160, in ?
    intf.rum(id, dispatch)
 File "/usr/lib/anaconda/text.py", line 496, in run
    dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 174 in gotoNext
    self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 582 in turnOnFilesystems
    thefsset.createLogicalVolumes(instPath)
 File "/usr/lib/anaconda/fsset.py", line 1472, in createLogicalVolumes
    entry.device.setupDevice(chroot)
 File "/usr/lib/anaconda/fsset.py", line 2066, in setupDevice
    raise SystemError, "pvcreate failed for %s" % (volume,)

System Error: pvcreate failed for <fsset.PartitionDevice instance at 0xb7a1d9ec>

Expected Results:  It should format the drives, install GRUB and install Fedora Core

Additional info:

Sorry if the error is not exactly correct but I had to re-type it all out again.

Comment 1 Jeremy Katz 2005-07-08 18:32:43 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.