Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162148 - Xen0 trouble loading aic7xxx module
Summary: Xen0 trouble loading aic7xxx module
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rik van Riel
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 179599
TreeView+ depends on / blocked
 
Reported: 2005-06-30 11:30 UTC by Chris Evich
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-24 20:43:25 UTC


Attachments (Terms of Use)
dmesg output (deleted)
2005-07-01 13:25 UTC, Chris Evich
no flags Details
strace output (deleted)
2005-07-01 13:27 UTC, Chris Evich
no flags Details

Description Chris Evich 2005-06-30 11:30:35 UTC
Domain 0 xen kernel has problems with scsi card on athlon system with stock FC4
xen kernel.  The card is an older Adaptec 2940 which works flawlessly using the
regular kernel.  The system is booting from a software raid mirror on the local
IDE disks.  The only thing connected to the 2940 is an old Teac CDR drive.
Everything works fine until the system tries to insmod aic7xxx.  At that point
it 'hangs', repeatidly resetting the scsi bus and sending abort commands.  I've
tried changing the IRQ settings for the card, disabeling xen (and the kernel)
acpi support, booting into emergency mode and insmoding aic7xxx by hand.

Comment 1 Chris Evich 2005-07-01 13:13:53 UTC
from emergency mode, tried loading aic7xxx_old but it did the same thing.  I get
the first piece of messages where it "downloads sequencer code" etc. It's
hanging just after that where it would normally start spitting out the
individual device info.

I moved the aic7xxx* modules in the xen0 module tree out of the way.  Now I can
get domain 0 to boot fine but have no CD Rom access.  I'll try running an insmod
of the module now that the machine is up.  Then I can copy-paste the error here.

Comment 2 Chris Evich 2005-07-01 13:25:33 UTC
Created attachment 116239 [details]
dmesg output

After moving the modules out of the way and getting Domain-0 to boot I strace
-ff -q -r -v -o /tmp/test insmod ./aic7xxx.ko.	Attached is the dmesg output
and the 'test' trace file though I don't know if it's very useful.

Comment 3 Chris Evich 2005-07-01 13:27:29 UTC
Created attachment 116240 [details]
strace output

did a kill -9 on the strace after letting it run for a while.

Comment 4 Stephen Tweedie 2006-02-24 20:43:25 UTC
This is a really old kernel and I expect it is fixed with the new rawhide
kernels --- certainly I've not seen any such SCSI problems on recent FC5test
kernels.  Please reopen the bug if you can reproduce with FC5test3 or rawhide.


Note You need to log in before you can comment on or make changes to this bug.