Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162142 - 3 * undefined operation
Summary: 3 * undefined operation
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 10:04 UTC by David Binderman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-30 19:07:34 UTC


Attachments (Terms of Use)

Description David Binderman 2005-06-30 10:04:08 UTC
Description of problem:

I just tried to compile package gtk2-2.6.7-4 from Redhat
Fedora Core development tree with the gcc 4.0.0 compiler and
the compiler flag -Wall.

The compiler said

1.

gtktreemodelfilter.c:1593: warning: operation on 'i' may be undefined

The source code is

      for (i = MAX (--i, 0); i < level->array->len; i++)

I agree with the compiler. This code would benefit from rework, because
it is wise to avoid doing predecrement on a variable in a macro call.

2.

gtktreemodelfilter.c:829: warning: operation on 'i' may
be undefined

gtktreemodelfilter.c:905: warning: operation on 'i' may
be undefined

Duplicates


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matthias Clasen 2005-06-30 19:07:34 UTC
Fixed upstream.


Note You need to log in before you can comment on or make changes to this bug.