Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162141 - 2 * operation is undefined
Summary: 2 * operation is undefined
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Monty
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 10:01 UTC by David Binderman
Modified: 2013-10-20 22:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-01 14:07:44 UTC


Attachments (Terms of Use)

Description David Binderman 2005-06-30 10:01:26 UTC
Description of problem:

I just tried to compile package gstreamer-plugins-0.8.8-6 from Redhat
Fedora Core development tree with the gcc 4.0.0 compiler and
the compiler flag -Wall.

The compiler said

1.

sndfile.cpp:1178: warning: operation on 'pSample' may be undefined

The source code is

	*pSample++ = bswapLE16(*pSample);

I agree with the compiler. Suggest better code

	*pSample = bswapLE16(*pSample);
	++pSample;

2.

sndfile.cpp:1369: warning: operation on 'pSampleW' may be undefined

Duplicate.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 John (J5) Palmieri 2005-06-30 14:18:27 UTC
Thanks for the report.  Can you create a patch and attach it here and also send
it upstream.

Comment 2 David Binderman 2005-07-01 08:15:51 UTC
>Can you create a patch

I could, but since I have no way to test it, then
it would be a risky patch.

Suggest forward bug report to upstream developers,
who are in a much better position to accurately 
patch and test.

Comment 3 Bastien Nocera 2007-02-01 14:07:44 UTC
GStreamer 0.8 series is long dead, and there doesn't seem to be any such plugins
anymore, so closing.


Note You need to log in before you can comment on or make changes to this bug.