Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162131 - OOo 1.9.112-1.1.0.fc4 creates configuration directory as ".openoffice.org%USERDIR2.0"
Summary: OOo 1.9.112-1.1.0.fc4 creates configuration directory as ".openoffice.org%USE...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 07:48 UTC by dexterthrowaway
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.9.113
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-03 20:45:14 UTC


Attachments (Terms of Use)

Description dexterthrowaway 2005-06-30 07:48:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The original OOo 2.0 beta included with FC4 created a configuration directory in the home users directory as ".openoffice.org2.0".

The recently released version creates it as ".openoffice.org%USERDIR2.0" and ignores (does not migrate) settings from the old ".openoffice.org2.0" directory.

Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.112-1.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1. Update to openoffice 1.9.112-1.1.0.fc4
2. Run any OOo application
3. Check home directory, the new .openoffice.org%USERDIR2.0 directory is created, the old is retained.
  

Actual Results:  Old settings are not used or migrated.

Expected Results:  Either:
the ".openoffice.org2.0" directory is retained.
or:
the old settings from ".openoffice.org2.0" are migrated to ".openoffice.org%USERDIR2.0".

Additional info:

Just a note, when I say ".openoffice.org%USERDIR2.0", the directory is literally that. %USERDIR is not a variable that has any value.

Another note... it seems to be this patch, but I'm not sure.
https://www.redhat.com/archives/fedora-cvs-commits/2005-June/msg00741.html

It seems to have been for 1.9.85, but this didn't occur in what was included in FC4 which was 1.9.104.

Comment 1 Michael Forrest 2005-07-03 03:30:55 UTC
I have found exactly the same behaviour with the recent release of OOo.

Comment 2 Caolan McNamara 2005-07-03 20:45:14 UTC
back to 2.0 in 1.9.113 (rawhide) will be in fc4 updates soon


Note You need to log in before you can comment on or make changes to this bug.