Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162115 - complex kickstart package list kills anaconda install
Summary: complex kickstart package list kills anaconda install
Keywords:
Status: CLOSED DUPLICATE of bug 160209
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-30 00:38 UTC by Fred Bourgeois
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-30 10:54:19 UTC


Attachments (Terms of Use)
kickstart file that causes problem (deleted)
2005-06-30 00:48 UTC, Fred Bourgeois
no flags Details

Description Fred Bourgeois 2005-06-30 00:38:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02

Description of problem:
When using a complex list of packages in a kickstart file, anaconda dies due to
package selection problems.  The anaconda-ks.cfg file is attached to this bug
report.  This file was copied verbatim from a previous interactive kickstart
installation that generated the kickstart file (on FC4).

Version-Release number of selected component (if applicable):
anaconda-10.2.1.5-2

How reproducible:
Always

Steps to Reproduce:
1. Boot from FC4 RescueCD
2. At boot prompt: linux ks=http://192.168.0.150/Fedora4/anaconda-ks.cfg
ksdevice=eth1 ip=192.168.0.200 netmask=255.255.0.0 gateway=192.168.255.254
dns=192.168.0.150
3. 
  

Actual Results:  Installation ceased.

Expected Results:  Install should have proceeded normally - the package list being used is taken
directly from the anaconda-ks.cfg file generated by a previous successful
installation of fc4.

Additional info:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1160, in ?
    intf.run(id, dispatch)
  File "/usr/lib/anaconda/text.py", line 447, in run
    (step, args) = dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 279, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 207, in readPackages
    id.instClass.setGroupSelection(grpset, intf)
  File "/usr/lib/anaconda/kickstart.py", line 1559, in setGroupSelection
    pkgs = grpset.hdrlist.pkgnames[name]
KeyError: ''

Local variables in innermost frame:
grpset: <hdrlist.GroupSet instance at 0xb79b3f8c>
intf: <text.InstallInterface instance at 0xb7afef0c>
name: 
fields: ['GConf2']
self: <kickstart.Kickstart instance at 0xb75cf90c>
n: GConf2
arch: GConf2

Comment 1 Fred Bourgeois 2005-06-30 00:48:47 UTC
Created attachment 116158 [details]
kickstart file that causes problem

Comment 2 Paul Nasrat 2005-06-30 10:54:19 UTC
This looks like a known bug fixed in rawhide.  See bug #160209 for workarounds (
use -name.arch, or how to create updates image).

*** This bug has been marked as a duplicate of 160209 ***


Note You need to log in before you can comment on or make changes to this bug.