Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162072 - mk-images script error causes buildinstall failure
Summary: mk-images script error causes buildinstall failure
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: ia64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-29 17:18 UTC by Prarit Bhargava
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-01 19:48:42 UTC


Attachments (Terms of Use)

Description Prarit Bhargava 2005-06-29 17:18:01 UTC
Description of problem: 
 
When attempting to build the installation, buildinstall fails to build images 
because of a script error in mk-images. 
 
 
 
Version-Release number of selected component (if applicable):  
 
anaconda-10.2.1.5-2 
 
How reproducible: 100% 
 
Steps to Reproduce: 
1.  Run pkgorder 
2.  Run genhdlist 
3.  Run buildinstall 
   
Actual results: 
 
buildinstall fails with: 
 
cannot find package kernel-BOOT in path /home/ia64/RedHat/RPMS 
kernel-BOOT does not exist for ia64 -- using kernel package 
unpacking /home/ia64/RedHat/RPMS/kernel-2.6.11-1.1381_FC5.ia64.rpm.ia64 
Wrote /tmp/makebootdisk.initrdimage.17216 (6652k compressed) 
mkdosfs: Need intended size with -C. 
Usage: mount -V                 : print version 
       mount -h                 : print this help 
       mount                    : list mounted filesystems 
       mount -l                 : idem, including volume labels 
So far the informational part. Next the mounting. 
The command is `mount [-t fstype] something somewhere'. 
Details found in /etc/fstab may be omitted. 
       mount -a [-t|-O] ...     : mount all stuff from /etc/fstab 
       mount device             : mount device at the known place 
       mount directory          : mount known device here 
       mount -t type dev dir    : ordinary mount command 
Note that one does not really mount a device, one mounts 
a filesystem (of the given type) found on the device. 
One can also mount an already visible directory tree elsewhere: 
       mount --bind olddir newdir 
or move a subtree: 
       mount --move olddir newdir 
A device can be given by name, say /dev/hda1 or /dev/cdrom, 
or by label, using  -L label  or by uuid, using  -U uuid . 
Other options: [-nfFrsvw] [-o options] [-p passwdfd]. 
For many more details, say  man 8 mount . 
umount: /tmp/makebootdisk.tree.17216: not mounted 
mv: missing file argument 
Try `mv --help' for more information. 
Wrote /home/ia64/images/boot.img (133999508k free) 
cp: cannot stat `/home/ia64/images/boot.img': No such file or directory 
Unknown file type (unallocated) /home/ia64/images/isopath/.. - ignoring and 
continuing. 
mkisofs: Uh oh, I cant find the boot image 'boot.img' ! 
Running mkcramfs  /tmp/instimage.dir.17216 /home/ia64/RedHat/base/netstg2.img 
warning: file sizes truncated to 16MB (minus 1 byte) 
Wrote /home/ia64/RedHat/base/netstg2.img (38896k)... 
Running mkcramfs  /tmp/instimage.dir.17216 /home/ia64/RedHat/base/hdstg2.img 
warning: file sizes truncated to 16MB (minus 1 byte) 
Wrote /home/ia64/RedHat/base/hdstg2.img (38576k)... 
Running mkcramfs  /tmp/treedir.7282/instimage /tmp/instimage.img.17216 
warning: file sizes truncated to 16MB (minus 1 byte) 
Wrote /home/ia64/RedHat/base/stage2.img (91152k) 
Writing .discinfo file 
timestamp not specified; using the current time 
 
Expected results: 
 
buildinstall builds installation correctly. 
 
Additional info: Discussed with Jeremy Katz, and I am working on a solution & 
patch now.  Jeremy has suggested sending this patch to anaconda-devel.

Comment 1 Jeremy Katz 2005-07-01 19:48:42 UTC
Applied your patch.


Note You need to log in before you can comment on or make changes to this bug.