Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162061 - new openoffice.org breaks pyuno bibliography program bibus 1.0.0
Summary: new openoffice.org breaks pyuno bibliography program bibus 1.0.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-29 15:44 UTC by Gregory Zornetzer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.9.113
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-03 09:50:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 51385 None None None Never

Description Gregory Zornetzer 2005-06-29 15:44:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The pyuno bibliography program bibus works properly under openoffice.org-1.9.104-2.  I upgraded to the newer openoffice.org-1.9.112-1.1.0.fc4 and reinstalled bibus.  When I attempt to insert a citation from Bibus (a python program), I get a seg fault.  That's very odd for a python program - the python interpreter should catch it.  Alternatively, I think that the culprit could be a bug in the newer openoffice.org-pyuno in the new openoffice.org.  I don't know how to debug it any further.  Note that downgrading to openoffice.org-1.9.104-2 (from the original fc4 distribution has fixed the problem).
Bibus v1.0.0 is available at http://bibus-biblio.sourceforge.net/
If there's a way that I can debug the problem, let me know.


Version-Release number of selected component (if applicable):
openoffice.org-1.9.112-1.1.0.fc4, openoffice.org-pyuno-1.9.112-1.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1.install bibus (as root), doesn't matter if you choose socket communication or pipe communication, but set it up for all users
2.run oowriter (as normal user)
3.run bibus (as normal user)
4.Click on a citation in bibus (create one if there isn't one already there)
5.From menu Openoffice.org, select insert citation
  

Actual Results:  Segmentation fault  (from bibus).  oowriter keeps running (but does nothing)

Expected Results:  citation mark and reference get inserted into the oowriter document

Additional info:

Normally, you'd think that this was a bibus bug, but since the program works fine on the previous version of openoffice.org, I tend to think that it's Openoffice.org, or pyuno that's causing the problem.  If pyuno is screwed up, then a lot more Openoffice.org addons will probably fail.

Comment 1 Caolan McNamara 2005-06-29 21:24:26 UTC
as a workaround does running as root...

echo 0 > /proc/sys/kernel/exec-shield

fix this ?

Comment 2 Gregory Zornetzer 2005-06-30 18:51:29 UTC
Cool, turning exec-shield off fixes the problem.  Is there a way that I can turn
off exec-shield in a more fine-grained way, or does something just need to be
recompiled?  

Let me know if there's anything else you'd like me to test.

Comment 3 Caolan McNamara 2005-06-30 20:28:03 UTC
I cocked something up, and I know what I did, but I'm not sure why it had the
effect it did, see http://qa.openoffice.org/issues/show_bug.cgi?id=51385

Comment 4 Caolan McNamara 2005-07-03 09:50:56 UTC
fixed in 1.9.113 in rawhide, I'll also push a fc4 update


Note You need to log in before you can comment on or make changes to this bug.